H7 Camera Board Bricked

Hey, so I am currently using an H7 camera for a project. Everything was working well until the board suddenly disconnected from the IDE. I’ve tried to troubleshoot by following the steps but nothing seems to work. When initially plugged in, the LED flashes green numerous times, then white, then into its default blue. For my project, I’m using an SD card and when I put that in, the main.py code runs properly as well.

IDE Troubleshooting steps:

  • No OpenMV cams found
  • Do you have an OpenMV cam connected and it is bricked? → Yes
  • Please select the board type → OpenMV Cam H7 (STM32H743)
  • Erase the internal file system? → Yes
  • Disconnect your openMV and then reconnect it… Hit cancel to skip to DFU programming
    (At this point the IDE loads to no end) → hit cancel
  • Unable to connect to your OpenMV Cam’s normal bootloader
  • I then place a jumper between the reset and boot pins and reconnect.
  • Nothing comes up in Windows Device manager
  • If i continue with OK → DFU firmware update failed, dfu-util terminated with exit code 74.

** EDIT** I have also tried troubleshooting on my mac and other windows PC with no luck. Additionally, I have changed cables and USB ports.

Any help would be great thanks!

Don’t cancel the DFU step, connect the jumper and reconnect the cam before that step.

I have the jumper in and I’ve reconnected it. Is there a certain time period youre meant to wait because it doesn’t seem like anythings happening and I’ve had it running for a few minutes.

No, just run the bootloader dialog again or try to connect and follow the instructions.

Here you canceled it, it says disconnect and reconnect (with the boot jumper connected).

I’ve disconnected and connected the board to the computer with and without the jumper cable and ran through the IDE instructions numerous times. I’ve let it load for a generous amount of time but have had no luck still. Any other ideas?

When you connect the boot jumper, and connect the cam to the PC, does it detect or show an ST/DFU manager in the device manager ? If not, can you try another USB cable and make sure it’s power + data cable. Also how are you connecting the jumper ? should be between BOOT pin and reset or 3.3v pin)

I have the jumper connected as such. When plugged into the PC, there is no detection from the device manager. I have tried with two cables that I know have worked in the past with this camera and in different ports too.

Screenshot 2021-10-23 104238

It could be the pin headers or the jumper is broken or not making full contact. Can you try to short boot pin (from the bottom ) to the 3.3v pin on the header above the USB connector and using a different wire ? Note if the cam is flashing green when powered it means that our bootloader is running and it did not start in DFU mode, it also means the hardware is likely fine. If that still doesn’t work, I can only assume the USB connector is damaged somehow.

More info: If the firmware is somehow corrupted, you won’t see any USB device after the green LED flashing (after the bootloader jumps to the main fw), or it will get stuck in a boot loop. You will only briefly see a CDC device until the green LED finishes flashing at this point it jumps to the FW… If you do see the green flashing it means you can use the IDE to flash the firmware and you don’t need the DFU mode at all… To do so, you need to start flashing the firmware from the IDE first then connect the cam, the IDE should detect it and load the firmware.

So this is what you need to do, disconnect the cam and start the IDE and hit the connect button:

  • No OpenMV cams found
  • Do you have an OpenMV cam connected and it is bricked? → Yes
  • Please select the board type → OpenMV Cam H7 (STM32H743)
  • Erase the internal file system? → Yes
  • Disconnect your openMV and then reconnect it… Hit cancel to skip to DFU programming
    (At this point the IDE loads to no end) → You should see this:

Now connect the cam, the green LED flashes and the IDE will detect it and flash the firmware.

Hey, thanks for the lengthy reply.

Following your initial suggestion, I connected the boot to 3.3V from the bottom using two different jumpers and when powered on the board’s LEDs do not light up so I presume it’s entered DFU mode? However, in the device manager there is no sign of an ST/DFU device.

I then tried your second suggestion by starting the troubleshooting process on the IDE without the camera attached but when I plug it in, the green lights flash, followed by the white and then into the main script with a repeated blue light. Nothing changes on the IDE. image
It remains on this window indefinately.

Are you absolutely sure the USB cable has data wires ? It seems the cam is only getting power. Can you try the with any other board you may have just to confirm ? If it is working then the USB connector must be damaged somehow.

I’m unsure of how to determine if the cables have data wires however I’ve been using these cables for the last few months with this board and everything has been fine. In terms of trying on another board, I don’t have one with me at the moment to check. If it was in fact the USB connector, is there any trouble shooting I could do on my own?

It is definitely the USB cable (hopefully) or the USB connector, and you could try any other board or USB device and see the cable is working or not (but not by just powering it, it needs to have some USB function).

Hey team,

Since I was unable to get the board to connect I went out and purchased the H7 Cam R2. Straight out of the box it connected to the pc with ease. Seems like the USB header on my other board must’ve been damaged somehow. Is there any way of getting it fixed?

Um, can you see any damage? If this fails the camera is kinda done though. You might try to hot air rework.

No visible damage that I can see. Can’t recall a scenario that put the header in any harm either.

I’m not sure what to do. Did the board touch metal? They product doesn’t randomly die.

Can you verify that the 3.3V pin outputs 3.3V?

The only metal I’ve used around it would be the probes of my multimeter. And yes I can confirm that both 3.3V pins output 3.3V, and so does the reset pin.

Mmm, not sure what is wrong. Buy another H7 unit from our website and I’ll refund you the cost of it (not shipping)