H7 Camera Board Bricked

I wasn’t able to obtain the same H7 Cam model as it is sold out but I have purcahsed the H7 R2 instead if that’s alright. And it terms of a refund, that would be really great thanks.

Please send me the order number.

I’ve just managed to brick one while updating firmware as well.

Developing on Ubuntu 20.04 running in vm on Ubuntu 20.04. IDE version 2.8.1
I have enabled USB in the VM for the openMV and DFU and can see in lsusb on the VM client OS.
Board is fresh from Adafruit. (OpenMV Cam H7 R2) (Sticker # 91102170 01251)

Initially, the Ide could see the board, but wanted the firmware upgraded.
So I tried the IDE firmware upgrade.
No joy, (hung in the download) so let IDE try with the DFU.

Exits from dfu-util with exit code 74.
show details says it could not find a file called …firmware/OPENMV4/openmv.dfu
That is correct, the .dfu version is not there or in the github releases.

So tried tools/runbootloader
download OPENMV4/bootloader.dfu
progress show a complete erase and download
but get exit code 74 from dfu-util
“Error during download get_status”

Hoping it still installed a good bootloader, I reboot without jumper and get a green flashing light

Using tools/runbootloader to download firmware.bin hangs
disconnecting and reconnecting does not start it

Reinstalling jumper and using tools/runbootloader to download firmware.dfu stops after erasing 44%

Given there are so many different issues, I suspect there is something about my dev environment.
Any suggestions?

I have a second unopened board, but given that they are hard to come by, don’t want to brick the second one.

Wait, is the light flashing green? This means the bootloader is fine.

Regarding the download… can you use a different computer? The IDE’s regular bootloader should never hang. That means something driver related is going wrong on your PC.

Thank you so much. It works. :ok_hand: :ok_hand: :ok_hand:

It’s alive!

After bricking when trying to update with the IDE on a Ubuntu client under VxWorks.

Downloaded ST’s programmer to the host Ubuntu system

copied bootloader.bin and firmware.bin from client to host
(They were at ~/.config/OpenMV/qtcreator/firmware/OPENMV4)

Shutdown VM so ST on the host could have the USB

Used ST to program and verify bootloader.bin at 0x8000000
Used ST to program and verify firmware.bin at 0x8040000

Stopped ST programmer, restarted openmv ide in the VM

Now IDE can see the hardware, is happy with the version, and can download and can see camera image on screen. (Yea!)

(There appear to be 2 repeatable, but minor bugs in the IDE.

  1. Can’t erase past block 44 when loading firmware.dfu
  2. Tries to down load a file which is not in the release. (openmv.dfu)

The DFU loader doesn’t work anymore for newer ST chips. It’s a can’t fix issue.

Regarding the missing file. That’s from our build process. @iabdalkader Should that file be generated?

No longer generated as it’s not needed, there’s a bootloader.dfu and firmware.dfu plus dfu-util is broken anyway.