H7 Plus bricked and IDE won't fix it

Plugged in my OpenMV Cam H7 Plus today (not new; have used several times). It flashes green 7 times, then white once, waits 2 seconds and then flashes red 3x, and stops flashing. Will not connect in IDE.

Steps so far: IDE asked if it was bricked,I said yes, did the disconnect/reconnect step (it would not leave that step on its own so I hit cancel to skip to DFU programming), disconnected H7, added jumper from RST to BOOT, reconnected, and waited. Device Mgr shows an unknown USB device (which is this) instead of a COM device. DFU device does not appear like it did in this other OpenMV post: https://tinyurl.com/y9mnkxag.

I also tried being impatient and not waiting for it to enumerate; and it timed out after 300 sec of not connecting.
Also tried other USB ports; same issue except some don’t recognize hardware change at all.

Anything else I should try? TIA

Connect the BOOT0 pin to RST and then check the device manager in windows. There should be an STM DFU device that appears under usb devices. Can you verify you see that?

It just appears as an unknown device (see attachments) in the USB list.


Mmm, that’s not a good sign. Typically this means the USB bus is damaged. Like 1 of the USB pins of the 2 is broken.

Was there any static electricity event or shearing on the USB connection?

I don’t have any other static electricity symptoms, not sure there. Have treated USB connections gently, no shearing.
Where do you think the pin is broken? On the PC? Arduino on same USB port comes up immediately as a COM and can upload sketches fine. No other USB port will ID the H7 either.

It’s either the cable or the camera being broken.

I’ve seen this issue before on my own hardware and it happens when one of the two USB data lines is broken. Check your OpenMV Cam PCB USB traces and the USB cable.