DFU Bricked and can't reset?

Hi there! My OpenMV camera suddenly stops working and I was hoping that someone could help me before I resort to just buying a new camera.

I unplugged it without properly releasing it from my windows machine and when I tried to plug it back in, the device would no longer be recognized. I figured it was the SD card, so I tried plugging in without the SD card, no luck. I tried a different windows machine and a linux machine with no luck.

I followed the reset instructions with the DFU reset. I disconnected the BOOT and RST pin without disconnecting it from USB power and the device was recognized. However, when I removed it from the USB port and plugged it back in - no luck. I did the same thing again, and I was able to get the IDE to connect. When I tried unplugging it and plugging it back in, no luck.

I then did a third time, but I sped through the process waiting about 10 seconds on each step instead of a few minutes like last time. Unit seemed totally bricked - no lights, no connection of any sort and the DFU would fail out.

Went to lunch, came back and repeated the process on a linux machine. The bootloader reset and I was able to connect, but when I disconnected and reconnected - same issue. Did the same thing again, but now I can’t get anything again.

The unit seems totally bricked. No lights, the DFU update on the times out and fails.

Any suggestions or do I just have to get a new one? Thank you.

Can you put it in DFU mode and just the Tools->Run Bootloader feature to load the bootloader.dfu file:

Use the OpenMV4 for the OpenMV Cam H7 and 4P for the Plus.

The camera should blink green when plugged in without BOOT0 shorted to VCC. If that’s happening then you should be able to use Tools->Run Bootloader to then load the firmware.bin file after unplugging and replugging the camera into your PC while OpenMV IDE is searching for it.

It took me a while to get back to this project…but I’m still having no luck. It’s pretty odd behavior actually - I plugged it in for the first time in a few days and it booted! Green light followed by blinking blue.

I ejected the drive, unplugged it to read through the github instructions. I plugged it back in, and then no luck. No lights and the computer doesn’t see a new usb device. I tried plugging into the wall to see if that could be issue, no luck still.

Any thoughts? The intermittent behavior makes me think that something is wrong the board hardware wise…

Yeah, it’s probably a hardware problem. Not sure how you can fix it…

Does wiggling the USB cable matter?