Bricked OpenMV

So i was using the openMV, everything was workingfine.Came back to it an hour later, and suddenly it was bricked . Followed the procedure on the ide to do the dfu setup shorting boot and rst. Went through the steps without fine. Reconnected the usb after that. But now no led turns on, and the device seems dead.
Any idea, what might be the issue? Or could you please point me in the direction on how to go about debugging the hardware and software.

Thank you for your time for reading this!

Hi, can you try the DFU procedure again? Note that when you short the RST and boot0 wires the device when plugged into USB appears as an STM32 bootloader device. If it appears as that in your device manager on Windows for example, then the board is fine and you just have to get through the DFU process without any issues.

Given you were able to get through the DFU process I would guess that the board is fine. However, it could have been possible to break the board such that the bootloader works but the regular firmware doesn’t. That said, after DFU finishes the regular USB bootloader which is that green flashing light on plug-in should always work as it doesn’t use anything other than USB.

Redid, the DFU bootloaded and now the leds are turning on, when USB plugged in. However, it does not seem to work after that. The oopenmv cam does a firmware reset, and reprograms on the ide, and press ok after the blue light has stopped blinking(this might take a while). However the blue light doesnt ever blink, what happens is just a non stop very fast white light blinking on and off. I have another openmv that is functional, and i ran into and issue with it once. Resetting firmware fixed it, and I could see that one doing the blinking blue led.

So in regards to you earlier answer. On plugging in the USB, the green light flashses on for a couple of seconds. Then, it blinks red once.Then it goes into fast nonstop white light blinking mode.The file system does show up on the computer, but the files are not openable.Everything freezes when trying to open the files

Thank you for your time!

Hmm, that sounds like a hardware failure. Email us with a receipt which should proof of purchase at one of our distributors for a replacement.

The white light which has multicolored pulses blinking fast is a hardware failure. The system jumps to a routine which blinks the lights when this happens. It’s not possible to hit however unless the hardware failed.

While we will do a replacement, take note of whatever you did before that might have caused this.

Thank you for your prompt replies. I will pm it to you as soon as i manage to get my hands on it. We are using the openmv for a robotics competition, and its on thursday. We were planning on ordering from DigiKey on monday, and have a 2 day delivery so we can get it by Wednesday. Is there anyway, you guys could ship it to us around that time. We would be willing to pay for the fast delivery, that wont be an issue. Again, thanks for the prompt replies!

Is there a tutorial I could follow to figure out which hardware got messed up?

Hi, our shipping is really backed up right now. It will take weeks for us to send you something. buy another from digikey right now and let me know when you want a freebie.

There’s no guide for how cameras get messed up right now. I suppose it usually has something to do with static shocks or the system accidentally being shorted out.

Again thanks so much, for all your quick response hope you have a good day!!
I was telling my friend about the fact that how scrolling these forums I have notices you guys are always soo good at responding. Its really appreciated!