Bricked unit, Firmware Update.

Was playing around with the board today. I am new to it, the IDE said firmware was out of date, so I figured I should update it. Long story short, it did not get through it, and now the Open MV cam is blinking the blue light twice. Blue-Blue-Pause, Blue-Blue-Pause. Nothing I do seems to get it to connect and update. Unit is effectivly bricked. How do I recover from this?

Hi, just try to connect and the IDE will walk you through how to DFU update the board. Are you on windows? If so this this is easy and 100% works. Just click the connect button and then say your board is bricked after connect fails to connect to your board.

If you are on linux or mac let me know.

Hello, thank you for your prompt reply.

For this I am running Windows 10 64-bit. I have tried multiple USB ports, biggest overall issue I seem to be having is the USB isn’t enumerating. Note this unit was working and running code, showing image, etc prior to me going down this firmware update path at the request of the IDE.

Here is a step by step account of what steps I have tried. Note items in “”'s are direct quotes from the software prompts, items in are my user actions and items in {} are my observations


  1. _2) [Try to connect]
  2. “No OpenMV Cams Found” → [OK]
  3. “Do you have an openMV cam connected and its bricked?” → [YES]
    “Select Board (M4)” → [OK]
    “Erase the Internal file System” → [Yes]
  4. “Disconnect your OpenMV Cam and then reconnect it…” [I disconnect and reconnect and wait, light is still blue-blue-pause (USB never enumerates as far as I can tell)]
    [After 15minutes of waiting (timed with stopwatch). I decide to disconnect, wait 30 seconds, and reconnect again]
    [Wait an additional 15 minutes, no change, so I decide to [click Cancel] on the OpenMV IDE Dialog ("Disconnect…)]
  5. “Unable to connect to your OpenMV Cam’s normal bootloader” → [ok]
  6. “OpenMV IDE can still try to upgrade your OpenMV Cam using your OpenMV Cam’s DFU Bootloader. Continue?” → [OK]
  7. “Disconnect your OpenMV Cam from your computer, add a jumper wire between the BOOT and RST pins, and then reconnect your OpenMV Cam to your computer. Click the Ok button after your OpenMV Cam’s DFU Bootloader has enumerated.”
    [I disconnect, add the jumper and reconnect]
    {There are no lights shown on the OpenMV Cam, and No USB enumeration as far as I can tell} [I decide to wait a few minutes, I set a stopwatch for 5 minutes]
    [after 5 minutes I click cancel, because I can’t click ok because it hasn’t enumerated, hoping that clicking cancel will provide me more instructions]
  8. Clicking cancel takes me back to the IDE._

Hi, okay, so you got to the last part. That’s the DFU update.

DFU update will fail immediately unless the device is connected. You should see the DFU device in your windows device manager under the USB device section as something like this:

You won’t see any lights or anything. DFU is silent and doesn’t let you know anything is happening. This is a pain with it. But, it should work 100% of the time. You just have to wait till it finishes. If it fails the IDE will tell you. Otherwise it’s working. DFU is painfully slow.

That said, for our next firmware release we’ve fixed our fast bootloader and the next DFU firmware update you do should allow the IDE to connect to our fast bootloader.

Anyway, please try again and just wait for the IDE to tell you everything worked or it failed. The IDE has a timeout built-into it which will kill the DFU update process it itself if it needs to.

Thanks for the help. I was able to get to do the DFU Update. I ended up switching computers. No matter what I did, I couldn’t get USB to enumerate on my main PC which is strange because it was working earlier.