Bricked M7 - Nop OpenMV cams found!

Good evening,

I edited a piece of firmware. After running the bootloader with the custom firmware i start the cam in openMV IDE. When running the edge_detection script and calling a custom function, the camera disconnects and a red light starts blinking(probably caused by a memory error because of firmware changes).

After disconnecting and connecting again the system is not able to find any OpenMV cam anymore. So is started the Bricked help flow and tried to connect my cam again. After that, the system is still not able to find the camera. When pressing on the cancel button after waiting for a while, a screen pops up which tells met that the OpenMV IDE still can try to upgrade my openMV cam using the DFU bootloader.

Clicking “OK”, the system suggests to connect a jumper between BOOT and RST and then reconnect them cam. When this is done, one has to wait for the cam’s DFU bootloader to be enumerated.

When i follow these instructions and plugin the cam again, no led is blinking en nothing is happening within the IDE. When after waiting for a few mintues, i decide to just click on the “OK” button, the IDE shows a Reprogramming message box which says: "(May take up to 5 minutes).

I tried this process multiple times but the Reprogramming screen keeps going on after 20 minutes.

Do you know how i can solve this?

Hi, the camera is unbrickable. So, we just need to work out what went wrong.

To reset everything using DFU will work. First what operating system do you have? Second… Close OpenMV IDE. Put your OpenMV Cam into DFU mode. Then reopen OpenMV IDE. Click connect and OpenMV IDE will ask you if your Cam is bricked. Say yes and follow the prompts to reset the camera via DFU. It should work.

You might have tried connecting while the IDE was in a bad state or something. You were doing the right thing though.

Thanks for your quick reply.

For OpenMV IDE i use WIndows 10.

I am happy to tell that i just tried your approach and it worked.