Newbie questions about getting started

I just got my Kickstarter OpenMV system, and am looking forward to exploring machine vision with it, and working on coding with my daughter. I have a question about how to get it working.

I downloaded the Mac OpenMV IDE (version 1.2), and plugged in the board via USB. The blue LED does blink, but the red LED is on continuously (no blinking). I saw the warning (at Home · openmv/openmv Wiki · GitHub ) that the red LED might come on occasionally, but I haven’t seen any comments on what a solid red LED means.

In the OpenMV IDE, I clicked on the “connect” button, and the message “OpenMV IDE must upgrade your OpenMV Cam’s firmware to continue.” I click OK, it asks if I want to erase the internal filesystem. Whether I select yes or no, it then says “Unable to connect to the boot loader! This fails sometimes - please try again a few times before giving up.” I’ve re-tried a half dozen times or more, with no luck.

I then opened Parallels to run Windows 10 on my Mac, and downloaded the OpenMV IDE there. I ran into problems where it couldn’t see the Cam/board, even when the “NO NAME” storage device mounted (in Windows) via USB. In some cases I was able to get it to start connecting (and updating the boot loader), with the red LED turning off for a while, but it never seemed to actually succeed in updating it. Instead it would lose the connection.

I’ve seen comments about using DFU if you’ve bricked the board, but since I haven’t uploaded anything, I don’t think I’ve bricked the board. But at this point, I’m not sure what I’m supposed to do. I followed the “getting started” page at Home · openmv/openmv Wiki · GitHub and in particular I did the “Upload the main firmware image located in openmv/firmware/OPENMV2/firmware.bin” in both the Windows and Mac version of the IDE, without success. Lower on that page it gives instructions for using DFU under Linux – do those same instructions work on a Mac? (It looks like I’d need to install Xcode in order to use the “make” command.)

To summarize, my questions are:

  • What does a solid red LED indicate?
  • Am I doing anything wrong when I try to update the firmware?
  • Should I install Xcode and try the DFU route (using “make flash_image” etc.)?
  • Is there some other method I should be trying in order to get the board to connect to the IDE?

Thanks in advance!

– Tom

Hi, a lot of folks have been having issues with the IDE. We’re about to release a new version that fixes the bootloader. I’m not done with everything just yet over here. But, I can release a pre-release for you. Give me a second…

Alright, here’s the download link. Note that I’m not quite done with all my changes for this release yet:

The new IDE has a much improved bootloader that should connect. But, if there’s a problem it also has the DFU programming built-in now so that it can overcome any issue. However, I just tested out the DFU programming backup and it looks like you’ll need to make sure to install Microsoft Visual C++ 2013 Redistributable. It’s a common installer shipped with more or less every app to be installed on a PC that used windows libraries.

As for your questions:

A solid red LED without you running a program means that the OS is accessing the file system. MAC is most likely writing info to the flash drive about the drive state.

As for updating the firmware, no, we’ve just had a hard time connecting to the thing… the new IDE does as much as possible to connect to the bootloader now. But, we have DFU support built-in now for backup. Luckily updating the firmware is something you don’t need to do often.

On Mac, if you want to use the built-in bootloader the IDE will tell you what libraries to install if there’s a failure.

Thanks for the updated code. Using it, I was able to have the IDE in Windows (under Parallels) connect, and even run some of the example code. It also indicated that I had firmware version 1.5 on the board. I clicked to upgrade it, but it would just hang at “connecting.” (Well, maybe not “hang” but it wouldn’t progress beyond that even after many minutes.) After I click “cancel” it asked if I wanted to try the DFU route, and I said yes. I followed the instructions to disconnect it from USB, connect the BOOT to RST pins, then plug it back in. The instructions said to wait for the boot loader to enumerate, but the lights on the board never lit up – none of them! After waiting a while, I hit “ok” to continue, then it says, “The program can’t start because MSVCR120.dll is missing from your computer. Try reinstalling the program to fix this problem.” I tried this a few times, but with the same results. I disconnect everything then start it up again, and it comes back saying that the firmware is (still) version 1.5.

Any suggestions on how to proceed (presumably with the DFU) for updating the firmware?

– Tom

Yeah, I just found that error myself. So, what’s missing is the Microsoft 2013 redistributable. You can get that online. I just updated our installer to include it.

As for your VM. Our IDE has issues on VMs because they can’t connect to the camera quick enough. Our bootloader has a timeout value of 500 ms that passes when the host OS passes the camera to the VM.

Just install Microsofts 2013 visual C++ redistributable for Windows, x86 and then it should work for DFU mode.

Sorry about all these road bumps. We’re a new project.

But, we have excellent help support since we are new.

OK, I’ll work on downloading that Visual C++ software and try it. Or I might bring the hardware into work Monday and try it on a real Windows computer. I’ll let you know how it goes. Thanks!

I’ve finished up all my code changes for the new version of the IDE. I’ll be releasing if in the next few days.

Using the v1.3 IDE on a real Windows machine worked! My board firmware is now at v1.9, and many example codes work on it with my Mac under its IDE. Thanks!

– Tom

Great, the official version of v1.3 will be coming out soon (like tomorrow) with all the fixes in.