Difficulties Connecting

Half of the time when I try to connect, the blue light stops flashing and the IDE hangs. The other time is get the picture below

In between lockups, I exit the IDE and unplug the module

Hi Sorry about these issues.

I can’t really tell what the problem would be from the error info you’ve given me. That said, something to try would be to reflash the device. See this: https://github.com/openmv/openmv/wiki/Using-DFU-to-update-your-firmware

Let me know if that helps.

From the random nature of the problem, I would infer that it may be something wrong with the USB connection. I would try to use a different USB port, different USB cable, etc. Hope that helps.

I’ll be posting a Kick Starter update with a link to the preview version of the new IDE for windows. I don’t have all the bells and whistles complete yet. But, the serial connection is good and it’s more or less usable. If the new IDE gives you problems then its either the firmware wasn’t flashed just right at the factory or the USB cable is bad. A lot folks have had bad USB cables.

Thanks. I’m running Win7 64 bit

Here is what I tried last night (without success)

  1. Reflash firmware
  2. Erase and reflash booloader (from IDE). Reflash firmware
  3. Change USB cables
  4. Change USB ports
  5. Reload IDE

When connecting the USB cable, the led flashes green a couple of times, white once and then drops into a repeating blue flash pattern. It mounts as USB drive and I can see the files. The blue flash stops when I press the connect button. Out of many many attempts I have only loaded a python script (one of the examples) successfully once or twice

When I first connected the module identified as Teensy Serial Port. I uninstalled and deleted the Teensy driver before I installed your serial driver.

Will try on a different computer this weekend

T

The Cam behavior seems fine. Mmm, okay, well, when the IDE preview comes out give it a try.

So I’ve downloaded and installed the 1.0.0 IDE. I’ve verified that the OpenMV USB serial port is present (COM17)

I’d didn’t see any way to set the serial port from the IDE. When I hit the connect icon i get the following error: Timeout while getting firmware version! The blue LED does stop blinking though

Does the IDE have a diagnostic mode that shows/captures the communication between the PC and the python board?

So, if you got a timeout error then that means the IDE was able to open a serial port on the board. Then it sent the firmware version command and got no response. So, the firmware on the cam is likely the problem.

Um, I’ll post in a bit how to update the firmware if I haven’t already.

Oh, the Ide automatically finds the correct serial port for the cam. It will only ask if there are two cams connected. You don’t have to worry about serial ports anymore with the new Ide. It filters serial ports by PID and VID so that only cam ports are considered.

Okay, just try updating the firmware using this:

Make sure to click the correct box when updating the firmware.

To load the firmware image onto your OpenMV Cam open the DfuSe Demo application and click the Choose… button in the Upgrade or Verify Action menu box (do not click the Choose… button in the Upload Action menu box). Then choose the above firmware image dfu file to select it to be loaded onto your OpenMV Cam. Finally, click the Upgrade button once you are ready to start the firmware update process. After you’ve finished updating the firmware you can optionally verify it if you like by clicking the Verify button.

As for the firmware to use, please see here: https://github.com/openmv/openmv/blob/master/firmware/OPENMV2/openmv.dfu.

Please don’t use the new IDE to connect afterward. Just use the DFU tool to re-flash. Then use the new IDE to connect. If it doesn’t work after this then I’ll send you a new one.

Upgraded and verified the firmware.
Removed the jumper and power cycled the module
I get the same error with the new IDE
It looks like I have a bum module …

Alright, email us with your info and I’ll send out another as a replacement next week.

Hi,
I just connect my OPEN VM cam on my Comp., I have the following observations :
When I connect the card on few USB ports I obtain few green blinks, then one red/purple blink and then blue blinks …it seems normal
I can see a new disk (31,0 Ko) with 3 files inside … it seems normal
when I launch OPEN MW IDE (1.1.0) : no OPEN MV Cams found !
I try almost everything to connect OPEN VM with IDE (using the Connect button) but I didn’t find the solution
Thanks

Hmm, the IDE filters out USB ports by the VID/PID of the Cam. Okay, try this:

Click the connect button while the Cam is not connected to the PC. The IDE will then ask you if you have a bricked OpenMV Cam. Say, yes, then select if you want to erase the flash drive or not. Doesn’t matter. Then the IDE will wait for you to connect the Cam to your computer. Do that. The boot loader will not overwrite the cam.

After that everything should work fine.

Note that the bootloader on the IDE won’t work on a VM. But, the IDE should normally run on a VM.

Sorry I should have sent an update when the replacement module arrived. It arrived (thanks much) but has the same problem as the first one.

I downloaded and installed the latest IDE and followed your unbricking instructions above. Selected the M4 board. That process completed fine on both modules. I can read the directory and there is a selftest.py files that wasn’t there before

On both modules the original fault remains - after I press connect, I get “Timeout while getting firmware version”

I believe the problem is caused by a conflict in your USB serial driver and pjrc.com Teensy USB Serial Driver. With your module attached, windows grabs the Teensy driver …

Hmm, okay. Might be able to fix this by installing our driver now. Please look into the IDE install folder:

see /share/drivers/openmv/openmv.inf. Right click on that and click install. It’s digitally signed now so windows should install it without any issues.

Also, the pycdc driver is there to if you want to install that also.

Note that you need to install the latest GUI from our website.

Thanks for quick reply. I could not install the .inf file by right clicking. Got the following error “The INF file you selected does not support the method of installation”. Same issue with the pycdc file

I did update the serial driver through Device Manager but still have the same problem - TImeout error while getting firmware revision. Also restarted the IDE and disconnected/reconnected the module …

Notice the title on driver version window (Teensy USB (COM17) Properties) Maybe this is leftover from how I updated the driver …

Can you try the firmware update process again since the driver is installed? Also, please delete the flash file system.

If the boot-loader works then the camera units are fine. Getting a timeout error on connect is very weird. This only happens if the cam takes over 500 ms to respond. Not sure why that would be the case however.

Reflashed bootloader.dfu and openmv.dfu using the DfuSe tool. The files came from here https://github.com/openmv/openmv/tree/master/firmware/OPENMV2
Could not connect
Reflashed using the bricked module process. I can occasionally connect but cannot run any examples.

On the times that I can connect here is the error message from Serial Terminal