OpenMV H7 Won't Connect to IDE

I just got my OpenMV H7 board in the mail and tried to test it. Following some tutorials, I downloaded the Latest IDE (v2.9.7) and connected the board through micro USB. The board lit up flashing green for a few seconds, then red for a second, then white for a second, then started to flash blue slower. Windows device manager sees the board and is even calling it an OpenMV board but the IDE couldn’t find it…

Here’s what I tried:

  • Different USB cables

  • Different USB ports

  • Updating the USB driver

  • Updating the USB driver to the driver that came with the board

  • Uninstalling and reinstalling the IDE

  • Restarting my PC

  • “Click the connect button while the Cam is not connected to the PC. The IDE will then ask you if you have a bricked OpenMV Cam. Say, yes, then select if you want to erase the flash drive or not. Doesn’t matter. Then the IDE will wait for you to connect the Cam to your computer. Do that. The boot loader will not overwrite the cam.” (It just times out)

  • Saying “yes” to if I have a bricked board and selecting OpenMV Cam H7 and following the instructions. (It, again, just times out)

Please help :frowning:

The board is not bricked.

You just aren’t using a USB data cable.

Use the right USB cable.

The cable I’m using is rated for 480-Mbps data transfer rate, what does it need?

I would probably recommend try to do a hard reset of the board by connecting the reset and boot pins. If that doesn’t work then I would recommend that it might be something to do with your firewall settings or antivirus blocking the connection.

I tried doing a reset by jumping the pins but that didn’t do anything different. I’ll try to check into the firewall…

If the blue light is blinking the firmware is running onboard. So, the issue is then that you don’t have a data connection to the board.

Either the PCB/connector is damaged or the cable is wrong. If the PCB and connector is damaged there’s no repair for the board.

There are MANY power only USB cables out there. Please make sure the cable you are using isn’t one.

If device manager on my Windows 10 PC can read the board then shouldn’t it be a good connection?

I’ve tried many USB cables and, yes, the power only ones powered up the board but device manager couldn’t see a connection ether. But a couple cables i tried make the board show In device manager but the IDE still can’t read it…

Oh, okay, maybe I read the above wrong.

If it’s in the device manager then windows can see it.

What does it appear as? The IDE is looking for a COM port. Does one showup when it’s plugged in? What type of device does it appear as? If it’s just a generic USB device then the driver must be missing. The IDE should have installed this for you.

See Images:
OpenMV H7 Cam Showing In Windows Device Manager

OpenMV H7 General In Windows Device Manager

OpenMV H7 Driver In Windows Device Manager

OpenMV H7 Port Settings In Windows Device Manager


That is weird.

Okay, the only reason for this is that the IDE is filtering for a specific PID/VID on the serial port.

Can you post the PID / VID of the serial port? It’s in the device details.

The driver bound to it though… which is PID/VID controlled.

Only other thing I can think of is that there’s something wrong with the main firmware.

A way to reset that is to click the connect button on the IDE. Go through the dialog to reflash the firmware, then plug and unplug the camera. The IDE should find the OpenMV Cam bootloader and reflash it.

If that doesn’t work then the DFU mode bootloader should fix it.

That said, the issue could be something else. I made the IDE logic pretty detect and saying what the exact error is so it’s definitely not finding the PID/VID combos it’s looking for.

See image:

Are you talking about this: because it just timed out when I tried this:

Yeah, that the right PID/VID.

I’m kinda stumped. It’s clearly connected to your PC and has the right PID/VID. But, the IDE can’t find the serial port.

The only thing I can think of is to reset the board via the DFU bootloader. Please follow the above steps again, then click cancel when the IDE is trying to connect to the board. It will then ask if you want to try the DFU bootloader. Say yes, follow the steps. The DFU bootloader is via DFU-Util which is a third party tool. It will update the firmware and things should work. If not… then I’m not sure what’s wrong.

Here is the result of Resetting the board via the DFU bootloader: :expressionless:

At this point are you interested in me mailing it to you to have a look at it yourself?

Yeah, send me a private message and I’ll send you my address. I’ll fix it up and then mail it back quickly via fedex.

Sorry new to the forum… How do I send PMs?

Click on the users name.