OpenMV connection problem


I have a problem when connecting the OpenMV to the IDE. The OpenMV is OV7725-M7 and has been updated to 2.5.0. The IDE is 1.7.1. OS is Windows 7.

When my OpenMV connected to the IDE, it will lose connection automatically after about half to one minute, and cannot reconnect again. I need to unplug the USB and plug it in again to reconnect, but it will only good for another half to one minute and then dead again. It happens every time no matter it has a program running or just left idle. Deleted on the board (blue LED stop flashing) and it is still the same. Tried different USB ports and cables does not help. However, I can see the OpenMV drive and access it all the time.

During the short connection time, it can run the example programs successfully.

The board is new. I just received it yesterday but it never have a good connection so far. Is there other anything I can try? Thanks!


Hi, I can’t tell the exact problem in this situation.

Please tell me:

What OS are you using, what computer, etc. All environment info.

Then, can you see if it works if the frame buffer is disabled very enabled. When the frame buffer is disabled much less info is being transferred over the USB cable. The disable button is in he top right hand corner.

Finally, is the USB cable you are using very long?

The problem you are having is new… Usually it works or doesn’t work. I haven’t seen it fail to work after a while. Where did you buy the camera from?

Hello! Thanks for the fast reply!

To answer your questions:

1, About the computer and the OS:
Windows 7 Professional / Service Pack 1
Dell Optiplex 9020 i5-4590 3.3GHz 8.00GB 64bit OS
I have tried removing all the USB peripherals (including mouse and keyboard) and have no good result.

2, Frame buffer Disable (the picture update stopped). Results are the same. Lost connection after a while.

3, The cable is 3 feet long. It is not very thin and marked USB2.0. It think the cable is good because I have been using it for some time without any problem.

4, I bought the broad from

Other information:

When I first connected the board to the IDE, it asked for a firmware upgrade (to 2.5.0) and I did it. Could there be anything wrong with the upgrade?

(Edited) more information:
1, I upgraded the firmware again and it doesn’t help.

2, After the auto-disconnection, it said “Timeout error while getting firmware version!” if I click the connect button without reconnecting the camera board.

3, If I plug in the board and wait one or two minutes before clicking the connect button, the connection will fail (“Timeout error while getting firmware version!”). The connection problem seems count from the time the board is powered up, not connection to IDE.

4, The auto-disconnection time is different every time, but it is usually around 1 minute.


I installed the IDE on another PC which runs Windows 10, and it works! I am not sure if it is the version of the Windows or hardware that caused the problem, but the board should be good. Thanks for answering my question.


Mmm, I wish I had this PC to debug on… I want to fix all weird serial issues like this.

Well, anyway, thanks.