USB Connecting problems after firmware update (RT1062)

I currently have a problem with the RT1062 cam.
We used two RT1062 cameras for a robotics competition a while back, they worked quite well we just had some minor connection issues from time to time but noting a PC / cam reset couldn’t fix.

We recently wanted to finalise our camera code since the next competition is coming up quite soon, they contacted as they should, and we updated the firmware to the latest version.
But after uploading the new firmware the IDE couldn’t recognize the cams anymore.

Strangely the cam is recognized by the device manager, but it seems like it can’t communicate.

Device manager log:

This device was stopped because it reported an error. (Code 43)

Error during a request from the USB device descriptor.

Driver name: usb.inf
Klassen-GUID: {36fc9e60-c465-11cf-8056-444553540000}
Driver date: 06/21/2006
Treiberversion: 10.0.22621.3672
Driver vendor: Microsoft
Driver section: BADDEVICE.Dev.NT
Driver rank: 0xFF0000
Driver with lower rank: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device has been updated: false
Parent device: USB\ROOT_HUB30\5&2bce96aa&0&0

The cable can transmit data and we tried everything on multible PCs

Everything accrued with two cameras so a hardware problem should be out of question.

I updated and cleared the file system via SBL (like in other blog posts described) which worked perfectly (USB correctly recognized, firmware could be updated, self-test successful…) but the issue remains.

I have trayed:

  1. Restarting everything
  2. Reinstellend the IDE multiple times
  3. Tried a not released version of the IDE
  4. updated windows (newest drivers)

Thank you in advance.

That’s an error during enumeration.

Do you have another PC you can plug them into? I’m very sure there’s no issue with PC enumeration of the RT1062. The latest firmware works fine on my PC.

Alternatively, you can downgrade the firmware back to a version when it was working.

To do this, use the SBL option, then when you click connect in the IDE select a specific firmware from the drop down menu and load it. You can see the firmware versions here: Release v4.5.4 · openmv/openmv (

v4.5.5 is the latest. v4.5.6 is the dev firmware.

First of all, thank you for your fast replay, unfortunately it has been a stressful week for me so i just got to answer now.

I am happy to say that the issue resolved itself. This post is just supposed to help people that are experiencing the same issue.

The fault was caused by the SD-Card.
I just assumed deleting the file system (before the firmware update) would also reformat the SD card, but it did not.

Since the old Disk file associated with the old firmware was still saved on the SD-card witch cased the cam not being recognized.

To unbrick it I disconnected the SD-card and reuploaded the firmware via the SBL mode. After updating the firmware i reformatted the SD-cards, after reinserting the card into the cam it could be recognized again.

This fix appalled to both our cams.