RT1062 bricked and cannot connect to IDE

I recently got my OpenMV RT1062 and it was working fine a few days ago, but now seems to be bricked. The board just has a green LED lit and my computer (IDE too) does not recognize that the board is plugged in. I am stuck on what to try next after reading through many of the forums. I have tried connecting SBL to 3.3V and in a separate try GND to RESET yet nothing changed. Has anyone had this/know how to fix it? Thanks in advance.

This is how the board looks and when plugged and how device manager does not read anything from the OpenMV com port.
OpenMVCam_deviceManager

Hi Jorge,

Yes, I can help you unbrick the system. It’s very easy.

Just connect a wire between the SBL and VCC pin and the camera and then plug it into the PC.

Click connect on the IDE and then follow the prompts. You should erase the internal flash drive.

Then, once it’s finished, you’ll need to unplug the device from the IDE, remove that wire, and then plug back in and it should be good to go.

Note, the IDE dialog at the end needs to be updated, the board will not automatically go back into camera mode while the SBL wire is connected as that forces the recovery bootloader. So, once the IDE is done recovering the firmware you have to remove that wire while the device is unplugged.

I have the SBL connected to the 3.3V pin and then I click the CONNECT button and click OK to “No OpenMV Cams found”, then select yes its connected and bricked, and then select the Cam RT1062 (tried normal and RT1062 SBL), and yes to erase the internal file system, but then I immediately get a timeout error: “Error: UsbHidPeripheral() cannot open USB HID device (vid=0x1fc9, pid=0x0135, sn=).”


The IDE should definitely find something attached to the PC when you click connect.

Okay, I’ll live debug this with you. I’ll reply via email.

1 Like

I am experiencing the same thing, was there a fix for this? I am using a mac however, but otherwise everything is identical.

Hi, does the camera not seem to be able to exit the SBL recovery loop? If so, then we need to replace the unit. The factory caught most of the failing boards for our first production run. But, somehow the workers let through QA units which did not pass our QA process. They are required to focus and register the boards on production. So, bad units should not have escaped. But, it’s possible that the same guy doing 200-400 units a day could have ignored a failure notice.

I’m not entirely sure. The unit is simply never recognized by the computer. It never mounts regardless of order of operations. Strange thing is I’ve been using this successfully for about 3 months now and in the last week I’ve had more issues which have only been resolved by rebooting the computer, simply closing and reopening open MV wouldn’t help. Last night rebooting stopped working too

If it had a manufacturing issue it would not have worked at all ever.

Send us an email at openmv@openmv.io. I can provide live help support today.

Just emailed you. Thanks so much