OpenMV Cam RT1062 - Unable to connect/use

I just received a OpenMV Cam RT1062 and it seems defective. I am unable to connect it (Windows 11 machines), with neither the mounted filesystem or the OpenMV IDE. Any help would be appreciated before I try to start the RMA process with Sparkfun.

Connecting with a good USBC cable, a green led turns on (it never blinks) and mounts as a storage device. Within the file system, I see three files (.openmv_disk,,Readme.txt). However, I am unable to open any of the files, any editor hangs until the device is unplugged. After about a minute the storage device unloads and a USB error is shown. The OpenMV IDE just tried to connect but sits on the “Connecting…” dialog box. It is impossible to hit cancel and the IDE needs to be force terminated.

Connecting the 3.3v to SBL pins and then plugging in the USB-C cause it to start up without mounting as a drive. Starting the OpenMV IDE, it will detect the connection and try to erase and flash the device, but it quickly returns a timeout error. Hitting OK to this error restarts the flashing attempt, leading to the same error.

C:/Program Files/OpenMV IDE/share/qtcreator/sdphost/win/sdphost.exe -u 0x1FC9,0x0135 -- write-file 0x20001C00 C:\Users\dmhum\AppData\Roaming\OpenMV\openmvide\firmware\OPENMV_RT1060\sdphost_flash_loader.bin

Error: UsbHidPeripheral() cannot open USB HID device (vid=0x1fc9, pid=0x0135, sn=).

Hi, it’s not defective. It’s working correctly.

However, there’s was a critical bug that was fixed via a firmware update. When you first connected it to the PC the IDE would have prompted to update the firmware… trying to edit the file before doing this outside the IDE causes the issue. As the bug was related to the file system startup.

Trying to recover it via SBL is the correct thing to do. The SBL bootloader should have worked, but, if it’s getting that error it means it doesn’t have privileges to open the HID interface the device appears as in bootloader mode to reflash it.

If you could launch the IDE in admin mode and run the SBL recovery again then it should be able to reflash it successfully with the latest firmware.

Note, the SBL recovery program shouldn’t require admin privileges on windows. It talks to the bootloader as a HID device. It’s odd that your machine prevents that from working by default.

I apologize for this roughy start to the product. Once you get the firmware updated it will be solid.

One note, it should have connected to the IDE easily and ran scripts without issues. The critical bug would have only happened on save and update.

Thanks, should I see a blinking blue led once I am in SBL recovery mode?

No, that means the firmware was updated and it’s working again.

In SBL mode there should be no blinking LEDs.

Thanks for your help, I got it working. Running the IDE with admin priv. did not work. I stopped using the installed version of the IDE and switched to the ZIP version, which then allowed me to flash. I may have downloaded the wrong installable version of the IDE, as it was asking me for a form #? Is that a form of registration?

Huh, yeah, that would be the factory IDE. That is not linked to publically. It sounds like you grabbed it off of github.