Single screenshot on camera then malfunction

I just purchased an H7 device and am struggling to get it working. The script is working as intended, however when I try to run the program takes a single screenshot, then appears to crash. The connection between the device and the computer is reset, and the board will not work until the connection is reset. I get the error “Error: A device attached to the system is not functioning.!” in the IDE and “USB device not recognized” in a Windows popup. Do you have any idea what is going on here? I am relatively new and cannot find any information in the docs regarding this. Thanks in advance

Sound like it’s damaged. Can you update the firmware on the board first?

I have tried to update the firmware multiple times. Still the same problem. I have also tried with different USB cables and different PC’s as well.

Where did you buy it from?

Bought from Sparkfun

Okay, buy another from them. Then send us the receipt and a paypal link to send a refund to.