New camera is broken


I just bought H7 cam, downloaded and installed the IDE. First connected to PC and ran IDE. It asked for update firmware of camera. I accepted. After upgrade when I try to use it doesnt. When I connect to camera and download any example project it works for 5 second and then board go to restart. After that IDE cant connect to the camera.

Tried to downgrade firmware to 3.6.6 and 3.6.4. Same effect.
What should I do? It is impossible to use board.

Hi, try the latest 3.6.7

Tried already. Same effect. The only script working good is basic LED flashing.
Any other script falls board to reset.
Can you help me? Or return money?
I can`t do anything. Just wasting my time.

As I mentioned before, it only works when not graphical processing.
If any graphical processing starts board crashes and goes to reset.
I think you sold me board from rejection because it was made in 2018.

Hi, I’ll ship out a new unit to you if you can give me a receipt for it. Please email with proof of purchase.

The 2018 date is the board revision date. The qrcode on the back has the build info.

I just recieved the same OpenMV camera from Roboshop had it overnighted for some Covid-19 development work. I have the same issue I plugged it in, and OpenMV IDE stated there was an update, so I pressed the update and now the camera is just blicking green/white without an sd card, and with an sd card is just dead. I’ve tried using the jumpers but when the jumpers are on I get nothing. Is it a bad camera? :question: :question:

Nevermind I got it working… its a bit quirky, but its updating now… and seems to be working…