Cannot connect to the H7 Camera Board

I’ve upgraded to the latest version of OpenMV IDE and now my camera won’t connect. When connecting the USB cable I do get the flashing green light, quick red, and then flashing blue. But when clicking on Connect in the IDE it won’t detect the camera. I’ve even tried the DFU option but that runs forever without ending. Is there something I am missing?

Try with some different USB cables.

I previously had used this cable and when I do connect it now all of the lights flash as expected. The cable hasn’t been used since I last connected the camera successfully. :frowning:

Bummer. Different USB port perhaps?

Well I tried something different. When I clicked the Connect button, and it stated that the firmware was out of date, I chose to Cancel instead of update. Then the camera connected properly and worked as expected. For some reason I cannot update the firmware. Is there something special to updating the firmware on the camera that is required to be done?

Hi, we update the camera firmware with new code constantly and fix bugs. You don’t have to update… and given how small our operation is some firmware updates brake things. But, generally you want to update the camera. The firmware is on our github and is updated constantly.

have your camera started yet??
I am encountering the same problem, I have upgraded the openmv to version 2.6.9 and camera is not working in simple code like “”

What exactly is not working?