OpenMV4 H7 Plus, no lights, not turning on

I have been working on an object detection project using the FLIR lepton 3.5 and a quantized tflite version of yolov8… I made the mistake of buying the original board, was very difficult to work within the memory constraints so I went looking for an H7 Plus. It seems like all H7 Plus versions were out of stock from most reputable sellers so I went to EBay (link) and purchased one there.

With my previous openmv board I soldered the pins and connected the Wi-Fi adapter fine. Did the same with this H7 plus and when attempting to boot the board by usb connected to my MacBook, there are no lights or any sign of the board turning on.

What kind of error could this be or did I buy a defective H7 plus most likely? Is there a way to interfere with the power connection with a messy solder?

Thank you for the help!

It may not have firmware on it.

Attach the BOOT0 pin to 3.3V and then plug into the PC and click connect in the IDE. The IDE should reprogram it then.

I connected the pin between BOOT0 and 3.3V, it seems like the IDE reprogrammed it, there were no blinking lights however throughout the entire process which is odd. I got this notification after the successful “DFU bootloader reset complete”

I follow the instructions and eventually it says “Unable to connect to tour OpenMV Cam’s normal bootloader!”

Right before I get the above notification this is what the Flashing Bootloader window displays during the upgrade:

It seems like it recognizes the device in DFU mode, and the upgrade is successful. During this process no lights. Afterward when I then follow the prompt I posted above, it gives me the unable to connect to your OpenMV cams normal bootloader.

My apologies for the multiple responses, just want to update as I try new things/make progress.

I followed this walk through: How to fix dfu-util, STM, WinUSB, Zadig, Bootloaders and other Firmware Flashing issues on Windows - Scott Hanselman's Blog

Which was referenced from this post: Custom OpenMV H7 plus board - flashing the boot loader - #8 by Joe100A

And now I have this response after connecting the BOOT0 and the 3.3v pins:

Also now my windows 10 recognizes the device as “DFU in FS Mode”. But still no lights and still no OpenMV cams found after flashing and upgrading the device:

Hi, after the bootloader has been loaded when you power the camera on again via USB it should have a flashing green light.

The IDE will need to connect to it though within five seconds before it jumps to the main program. Otherwise the system will run blank code and crash.

So, after it’s been loaded via DFU are you saying you do not see any green lights at all? And you selected the firmware option for the H7 Plus to load?

From the looks of things it seems to be the case that you loaded the bootloader. So, you should be able to load the main firmware now.

1 Like

No lights at all.

Right so after loading the bootloader which seems like I did, it does ask me to load the firmware for the H7 Plus, but then it seems like I get stuck in the loop where I load the firmware, it says its successful, it tells me to disconnect the jumper wire, then reconnect the cam- then it says a board in DFU mode was detected what would you like to do? (Install the latest firmware (v4.5.0))…

If I try to reconnect the board without the jumper wire between the pins I just sit at this window indefinitely:

I guess the error that I get that is consistent after all these steps is, “Cannot connect to your cams normal bootloader”, which makes me try the DFU Bootloader and connecting the pins, but I have already gone through that step many times so I guess I am confused why the bootloader I install with the two pins connected never stays on the board/gets saved.

I connected the jumper again, went into tools and uploaded the openmv.dfu firmware and it was a download that took longer than usual but it seemed successful:

Now I am at this window:

I disconnect the jumper cable, disconnect and reconnect the board and now I am waiting to press OK (blue light test), after 5min still no lights or blue lights.

Okay, there’s two things that are happening:

  1. There’s a bootloader which is loaded via DFU onto the chip. The chip has a rom bootloader that allows you to load the bootloader for the camera. We cannot load the bootloader + main firmware here though since there’s a bug in the rom bootloader which only allows it to load up a few sectors… enough to fit our bootloader but nothing else.

  2. Once that bootloader is loaded you should never see DFU stuff again. Once the 3.3V wire is removed from BOOT0 you should never need to see it again. Our bootloader will take over from there.

However, if you are not getting a green light after the IDE says it successfully loaded our bootloader and after you remove the 3.3v from BOOT0 then something is wrong with the board.

We’ve been out of the H7 for over a year now. Since it’s from eBay… it might have been broken before and they are reselling it. Given it appears via USB the chip works. However, it’s odd that our bootloader doesn’t run. Maybe the LEDs could be broken. I would check the windows device manager and see if the out bootloader appears as a com port for about 5 seconds. If not then something is wrong with the board.

1 Like

OK thank you I ended up determining the previous board was compromised. I got a new H7 Plus a recently and now it works, flashing blue blinking light, detected by USB, but once I plug in the 3.5 Lepton with the adapter to the board the board is no longer detected and has a slow flashing blue light. Is this due to the old firmware potentially on the board?

Could be. The flir lepton definitely should work with the board.

1 Like

Ok oddly enough, I was able to upgrade the firmware no problem with the sensor: OV5640 attached. When I disconnect the board and reattach the FLIR Lepton with the adapter the board does not turn on or is recognized when plugging in the board. It maybe a potential clash with an unregistered OpenMV board vs a registered open mv product (lepton adapter)? I just tested the FLIR sensor by plugging it into my original OpenMV non-plus board and it worked no problem. And I just registered this cam with the OpenMV IDE too.

The H7 plus wasn’t manufactured by us. Maybe there was a different choice on the capacitors to save cost. The flir sensor causes a brownout which you need to handle when it boots. The only way for the system not to crash is to have significant capacitance on the 3.3V rail.

Try adding a large uF cap to 3.3V. Like 470uF.

1 Like

Do you have a diagram or example of how to attach one of these capacitors to the rail? Do I need one pin in the 3.3v and another attached to a ground? Thank you for your help with all this.

Basically, if you remove the shutter from the flir lepton this will also allow you to test if the issue is indeed a brownout. Typically the lepton will close its shutter on power on and that causes a surge on the 3.3V rail which can brownout the camera. You can see this happening if you attach a scope to the 3.3V rail.

Our system is designed to handle this… so, it shouldn’t happen. But, this is the only reason why I can think it’s not working.

Otherwise, since you bought a clone the SPI bus on the camera connector may be bad. I dunno.