Green LED keeps blinking endlessly - H7Plus

Hi! my H7plus keeps on blinking green after I tried to install the latest firmware of it. I followed the troubleshooting steps of the IDE when the cam is bricked but apparently, whenever I’m at the phase where I need to disconnect the h7plus on my computer and remove the jumper wires from the boot and reset pins, the h7plus keeps on blinking green endlessly when I reconnect it as said in the IDE. What should I do? I’m just a student and it’s my first time using an openmv device. I’ve already read the forums that may be related to my case but nothing works. I’m sure my microUsb cable works fine because the computer detects the device when it’s in DFU, but when I remove the jumper wires from boot and reset pins, the device just keeps on blinking green and is not being recognized by the computer.

Well, it’s not broken… the LED wouldn’t blink if it was.

So, you did this:

  1. Connect BOOT0 and RST
  2. Plug into PC.
  3. Click connect in the IDE and follow prompts.
  4. When prompted the IDE will tell you to remove the camera, remove the BOOT0 and RST, and then tell you to leave it disconnected.
  5. The IDE will then show a new window saying to connect the camera now that has a progress bar.
  6. Plug the camera in and the IDE will start loading firmware.
  7. The IDE should then connect.

We have a pretty advanced flow for this in the IDE now I’ve tested that should cover getting you operational again.

Thanks for the response, but I already did those already. I’m always stuck at the point where the IDE will then show a new window saying to connect the camera that has a progress bar. When I reconnect the camera without the jumper wires, the camera blinks green and never stops. Should I wait an hour for it?

No, when the IDE is showing the progress bar and saying to plug a camera in you should just be able to plug the camera at that point in time and the IDE will reload the firmware. It should be pretty seamless.

Does the IDE connect to the camera and say erasing and then programming and get stuck? Or does it just never find it? If it never finds it but DFU reloading works then this probably means the serial port driver for the camera wasn’t installed.

The IDE should have installed the serial port driver for you though.

If the camera is blinking green continuously it’s in bootloader mode, then jumps to bad firmware, resets, and then goes back to the bootloader again. When this is happening the IDE should be able to connect to it and it should be appearing and disappearing on the USB Bus.

Yeah, the IDE never finds it.
Can I install it manually? I really need the device for my simple project in school and I do not have enough time to buy and wait for another one.

I tried another method of flashing the firmware using STM32CubeProgrammer. I followed the steps of the tutorial by SingTown - OpenMV Cam video tutorial 41 - New DFU Upgrading Firmware When I tried to flash the openmv.bin file, it was still blinking green after I reconnected the camera without the jumper wires. Is there still any chance to fix it?

I Did It!!! my H7plus is now fixed, although I do not know if my solution is right but all I did is to install both the bootloader and firmware (.dfu through the IDE and .bin through STM32CubeProgrammer). I tried from 4.0.0 up to 4.1.2 release and the 4.1.2 fixed it. Also, I did install both OPENMV4 and OPENMV4P.

Great to hear. Not sure why this was so hard. The IDE software has a lot of code to handle every possible issue. Guess I missed something.

1 Like