OpenMV IDE always crashing

Just installed all the OpenMV drivers on Windows 7 (64bit), everything went on smoothly as expected.

But whenever I open the IDE, it shows the splash screen for split-second and then crashes.

I have tried all the solutions described on this page http://forums.openmv.io/viewtopic.php?t=289, but it’s still crashing

I have restarted the computer and unplugged/re-plugged the camera but no luck.

Any advice for me please?

Can you run it in admin mode? Please right click on the IDE and say run as administrator. Do this on the exe binary. I can confirm that the IDE works fine on all my windows test machines. Not sure what’s going to, but, I think it would be some write permission issue.

Sorry forgot to mention, already tried that, via start menu as well the exe in the bin folder.
No error thrown, nothing captured in the events log, very strange.

I will try again on a different machine.

Can you try an earlier version of the IDE? They are all available for download on GitHub.

I found this in InstallationLog.txt (last 3 rows)


[657071] Control script callback “FinishedPageCallback” does not exist.
[701886] run application as detached process: “C:\Program Files (x86)\OpenMV IDE\bin\openmvide.exe” () “C:/Users/kashif”
[701970] Critical: QWindowsPipeWriter: GetOverlappedResult failed. (No process is on the other end of the pipe.)

tried 1.8.1 with exact same problem.
will try tomorrow on a different PC

Tried on another computer and it worked great without any modifications.

The install log is usually deleted on finish. I suspect the IDE installer binary was corrupted.