M7 not connecting

Hello! I’m working on an M7 (OV7725-M7) cam, but I can’t connect to it with the OpenMV IDE. When I connect the camera to my computer I see briefly the green light flashing and then turning off. I have tried the DFU reprogramming, and I get a runtime error. What can I do to fix this? :smiling_face_with_tear:

Click connect on the IDE when no camera is connected. Follow the prompts, and then plug your camera in when requested. The IDE will reprogram it and then it will work.

1 Like

Hi, It doesn’t work for me, if I have followed the steps correctly, hope I have done so. Here is a quick gif of the steps I followed m7 - Gifyu

I can add that when the runtime error comes up and I close it, I can see the green flashing continue

Ah, okay, that’s just our new bootloader not working for you. Please install the last release of our IDE and try this again and it should work.

We updated the bootloader to be faster but it doesn’t work on some PCs. I’ll need a log of the USB traffic to figure out why.

1 Like

I think I have already the latest version of the IDE, but still, I’m still getting the same error, I don’t know if there is a way to know my version, but I uninstalled and installed back again, and still not working. By the other hand, how can I provide you with the log of the USB traffic?

I have the OpenMV IDE 2.9.7

1 Like

Thank you so much Kwabena, everything working fine rn!

I got almost the same problem:
OpenMV3 R2

Mac Pro 6.1
macOS Monterey 12.6.3

Installed openmv-ide-mac-2.9.7

When I first time plugged OV7725-M7 board, it works almost normal, connected. And LED flashed properly with write/green and blue light.
But pop up dialog asked me to upgrade software (or FW, I do not remember).
During upgrade it tells something like timeout and brakes the process. And after that nothing works.
I plug OV7725-M7 board to the mac, but it dies not recognize it. In USB section (About system) it does not present, onboard LED blinked 5 times and shut down.
It seems like I need to install some proper driver or maybe downgrade the openmv-ide-mac-2.9.7 to openmv-ide-mac-2.9.2 ?

Hi, please use the previously released version of the IDE. The one we put online as the latest has a sped up bootloader which doesn’t appear to be compatible with some folks machines. I don’t quite know what’s causing the issue however on why it doesn’t it work.

I’ll be building a new IDE release and making that available in the coming weeks. I have a fix for the speed up which is to slow it back down again in the meantime.

I pushed the latest firmware to the previous IDE so it will still give you the latest firmware.