Error- Timeout error while getting firmware version


I recently got a Cam m7. I try to do the introduction tutorial but when i try to connect the camera to my PC with OpenMV IDE i get this error “Timeout error while getting firmware version”.
Then it tell me “Do not try to connect while the green light on your openmv Cam is on” but it is blinking blue.

I’m lost and i dont know what to do.

Hi, what version of the OpenMV Cam do you have? Do you have the M7 one? If so, do you get the timeout error as the first problem on connect? Or, did you update the firmware?

Thanks for the answer.

I have the M7 Cam. I get the error when i press the connect button on OpenMV IDE. I can see the drive with the file but i cant get OpenMV IDE to show me the firmware version.

Okay, the firmware might be bad. We can recover however.

Do this - unplug your OpenMV Cam from the PC. Click the connect button. OpenMV IDE will warn you about not finding any OpenMV Cams. Follow the prompts for your OpenMV Cam being bricked. Then, when it gets to the part where it asks you to plug the camera into your PC do so. The IDE should then update the firmware. After doing this the camera should be operational again.

I did what you asked. The problem is it didnt update the firmware. Then it asked me do the update with the DFU Bootloader and to put a jumper cable. The process worked but i still cant connect the camera to openmv IDE. Then i tried something different. I installed OpenMV IDE in another PC(Win7, administrator profile, USB 2 port) and it worked. I could connect the camera directly and get the video running. So i dont know what may be faulty in my 1st PC (It’s a Win10, user profile, USB 3 port).

Mmm, okay, question. On the first computer does the uPY flash drive appear when you connect the device? If that doesn’t appear it means the OS is blocking USB access. Usually the IDE fails to connect if that’s the case.

How do i see if the uPY flash drive appear? I dont see any document that talk about it.

When you plug the camera into your PC you should notice a USB flash drive that’s about 96kb large appear. Windows explorer will show it as a standard flash drive. That’s the builtin uPY drive.

Thanks for the explanation. Yes i can see uPy drive.

On the previous PC was the drive appearing immediately before or did it take a while to appear? It taking a while to appear means the OS is blocking access.

It appear quickly, less than 3 sec.

Mmm, okay, not sure what the problem is.

Well, it’s is working on a PC you can use? If so, then you should be good to go. Let me know if you need anything else.

I’m having an identical problem, however when I tried this process, it didn’t work. When I connected the camera (and pressed “connect”) I go the same Timeout Error while getting firmware version. When I went through the process of disconnecting the USB to try to force a reload of the firmware, a popup appeared indicated it was erasing memory. The progress bar got up to 84% and the system froze. After about 5 minutes, I got a another timeout error message - not the same one as before. If I try to connect, I get another popup that says if it can’t start the download within 5 seconds, to hit cancel. When I do, it then pops up a failed semaphore message.

Do you have any suggestions?

Um, this kinda of problem happens when your PC drivers aren’t completing read responses. We’ve seen issues like this occurring where I’ll send message to the camera and the camera will respond and then the OS won’t bother delivering the response to the IDE. OpenMV IDE actually has a work around in it to ping the OpenMV C when this happens to unstuck the OS.

Anyway, you can change the serial timeouts using a command line argument with OpenMV IDE.

Please launch OpenMV IDE on the command line with --help and the IDE will display all arugments it can take. Then increase the read and write timeouts from 5 seconds and 3 seconds respectively to something higher. That said, the timeouts are already very long… So, I don’t think they are the issue but it’s something to try.

Sorry. My stupid. I selected the H7 camera, not the M7.

Still need help?