I can't connect to M7

…, after a green flash and erasing atempt I get timeout.
I tried dfu load and all I get is “Cannot open DFU device 0483:df11”.
any tip?

Hi, can you document more what you did? DFU loading should fix the camera.

After a long time without using it, I tried in my new laptop (w11 home edition), when I plug in the usb cable, green led flashes 5 times then stop. When I try to download de .dfu I get the timeout error.

Hi, it’s not in DFU bootlaoder mode. You need to connect BOOT0 to RST. Then try again. The green LED flashing means it’s running our firmware still and the ST default bootloader.

i have an M7 and try dfu mode but it give me the same error 0483:df11

That’s the PID/VID.

there is a way to correct it ?


Hi, that’s now the PID/VID for the firmware.

Sorry, what is wrong now?

im not able to connect to it either in dfu mode or normal mode

Hi, okay, I think you should check if the STM DFU util can still connect. Put the camera into DFU mode and go to openmvide/share/qtcreator/dfuse/DfuSeDemo.exe.

This app should find the camera. Then, click the upgrade or verify box and select choose. Find the openmvide/share/qtcreator/firmware/OPENMV3/bootloader.dfu. Then load and verify. Afterwards, select the openmvide/share/qtcreator/firmware/OPENMV3/firmware.dfu file and then load and verify.

Your camera should work again. Note: The firmware path I gave you is for the M7 unit.

Work great! what a nice software thank you for tehe tips 5star for your service!

1 Like