Issue with MK7 Camera

Hi there,

I’ve been using an OpenMV MK7 Camera (STM32F765) to develop a project over the last few months but have been unable to connect to the light today.

The camera has worked fine but it did have a similar issue where the firmware corrupted and required a reflash but it work again as normal once this was complete.

I have tried to reflash the device using the IDE for bricked devices as before but it just completes and then resumes flashing white. I have also tried the bootloader DFU (connecting BOOT and RST) but this also completed and after enmuration, resumed flashing white rapidly.

Are there any other ways to recover the device?

Also as a side note, I also noticed that the camera had been running incredibly hot over the last two weeks. It was able to carry out the intended python script as expected but was so hot I used an IR camera over it. The IR image is below but the device was running at 100~ degrees celesius. This was an immediate ramp up in temperature when power was applied to the device (either through the uUSB or by the Vin and GND connections at 5Vs from a Raspberry Pi GPIO Header).

Hi, it might be broken. The core definitely should not be 100C. Can you give a summary of what you plugged into the system?

The only things plugged into the device would be the micro USB connected to a Raspberry Pi 3 and the odd time a MAC Notebook.

The pins plugged into the camera would be Vin and GND when the micro USB isn’t needed to load a new Python Script, view the frame buffer or for power. P1-5 are used as simple GPIO input/outputs from the camera, scanning the video feed for blobs and outputting the detected blobs as a binary pattern that the Pi interprets. One pin acts as an input to hold and reset the python script until the Pi calls for it to scan.

While testing a few ways to mitigate the heat the device was giving off, I had the camera powered using Vin and GND again. As before the device was heating up so I was using it to test a thermistor for use in heat detection in my project. After a while the LED stopped, flashed blue then seemed to die.

I took out the power jumpers and attached it to the uUSB and now the flash drive appears and the LED flashes blue (2 flashes followed by a pause).

I can now access the ERROR.LOG file and it states the following:


The device is still heating up to very high temperatures. I stuck a small Raspberry Pi MCU aluminium heatsink on the MK7 MCU which has helped bring the temperature down but it is not the only component thats hot. (See top right crosshair for current location of max. temp. detected)

Sounds like a short. Do you have a USB current meter ?

A current meter would verify this. That said, I’m unsure what can be done. It looks to be like the camera has been damaged.

I will be able to check the current on Tuesday as we are off for a long weekend over in the UK. I wouldn’t have any current meters except at work.