OpenMV Cam M7micro very hot

A few days ago I bought the openmv and wifi and lcd shields.
The tests I have done with both the wifi card and the lcd board have been satisfactory, but I have noticed that the microprocessor gets very hot, I even have a radiator to cool it. I have worked with openmw for an hour or so each time, testing and modifying the different examples. It has gone quite well but I’m afraid it will burn if I have a long time connected.
Can it be clock frequency problem?
Thank you for your attention.

Um, how hot does it get? The processor should not get hot. The VREG can get pretty warm however when dropping 5V. But, it should never be so hot as to burn you. Just warm.

Well, I measured the micro temperature and at 3 minutes it is set at 50 ° C and it reaches 50.83 ° C maximum.
The regulator marks 3.30v output and the temperature oscillates between 44ºC and 45,45ºC maximum
Measurements have been made for 6 minutes.
It is right?
Thank you

Seems about right. That’s just the VREG. No issue. Our board draws 150-200 mA. It’s not drawing an exactly… ultra low current. The STM32F7 chip is effectively a Pentium 2 processor.

Here’s an F7 Discovery Board (Note it’s not running OMV firmware, just a loop in MicroPython).


This is my OpenMV camera running AprilTags:


The temperature is maintained at 49 °C and 52 °C after 20 minutes of testing.
With the selftest example and gives me an Exception: INTERNAL ADC TEST FAILED VBAT = 3.407233v when it reaches values of 50º.
I am thinking, also, to put it in standbye or similar if it does not have to work.
Thanks for everything

The seller test scipt is meant to be run at a very specific point in time when the camera is not hot. The script failing is not an issue due to the internal ADC drifting due to temp.

Thanks for the explanations. I’ve tried many of the examples that come with the IDE and they all work fine, I’ve even modified some. The temperature stays at 50-52 ° C, but it works.
But today, I do not know what happened that the USB flash drive has disappeared. A worked for the LCD, but the PC did not detect the connection or USB flash. The option has been reprogrammed, but now I am with the camera with the blue led blinking (… … …) and nothing else.
How to continue?
Sorry for my English.
Thank you

That’s the windows 10 creator update. We’re about to release a new version of the IDE to fix that. Please just wait for the update email which will come out today.

I have downloaded the new version of the IDE 1.6 and have reprogrammed the openmv in mode DFU but there is no way to connect with the usb flash drive. The blue LED blinks, but it does not do anything else.
With a sdcard in which I could record the application works correctly, but does not recognize the internal disk.
By applying the connection between boot and rst, the PC recognizes an STmicro DFU device in both Linux and W10 and in theory, allows reprogramming but then after 4 minutes and following the instructions the blue led flashes (… … … ) and when reconnecting does not recognize the Internal disk.
It worked fine and I tried a few scripts.
What I do?.

Hi, what operating system are you using and what OpenMV Cam? The M7? We’ve verified that the SD card issue has been fixed for Windows 10 Creator with the new firmware. This could be a different issue. Please provide me a detailed description of your setup.

OpenMV Cam M7 purchased on the 15/5
OS: Linux Ubuntu 17.04 and the same in Windows 10
1.- Open OpenMVIDE in Linux Ubuntu 17.04 and connect:
No OpenMV Cams found!
2.- Do you have an OpenMV Cam connected and is it bricked? yes
Please select the board type
3.- ARM Cortex 7 OpenMV Cam (STM32F765) OK
4.- Erase the internal file system? Yes
Disconnect your OpenMV Cam and then reconnect it
No lo reconoce
5.- Cancel
6.- Unable to connect to your OpenMV Cam’s normal bootloader! OK
OpenMV IDE can still try to upgrade your OpenMV Cam using your OpenMV Cam’s DFU Bootloader.
7.- Continue? OK
Disconnect your OpenMV Cam from your computer, add a jumper wire between the BOOT and RST pins, and then reconnect your OpenMV Cam to your computer.
8.- Disconnect and put jumper wire
Click the Ok button after your OpenMV Cam’s DFU Bootloader has enumerated.
Terminal linux (in windows10 reconize DFU):
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 0483:df11 STMicroelectronics STM Device in DFU Mode
9.- OK
Reprogramming (may take up to 5 minutes) No flashing leds
It’s been 3 minutes and blue led flash …-…-…-
DFU firmware update complete!
Click the Ok button after your OpenMV Cam has enumerated and finished running its built-in self test (blue led blinking - this takes a while).
Does not recognize
10.- Disconnect
not jumper wire and reconnect
No OpenMV Cams found!
With a sdcard and a app works perfectly, but not de USB flash drive internal

Okay, the USB obviously works and the camera seems fine…

So… okay, on linux I notice that it takes on the order of 10 second for the camera to be ready. But, on windows it’s ready immediately. I don’t think re-flashing the firmware will help.

… I’m somewhat at a loss for what is wrong. Can you try on a different computer? From what I see your camera is fine. If you can re-program with DFU and the blue LED flashes the system is working right. No problems.

I have recorded the firmware from Windos 10, from Ubuntu, from Mint and it is impossible. When reconnect, the blue led flashes and the IDE does not recognize the internal disk or bootloader. Only flash
But if I save the examples in a sdcard, if they work in the camera and the blue led does not blink, but without being recognized by the IDE. In the dfuse directory on Windows10 there are programs that recognize opencam in dfu mode, with the jumper inserted.
See images.
Any solution
Thank you

So, you are saying the OpenMV IDE can never connect to the camera but DFU can? Is that correct? The only thing I can think of that would keep the system from working is that you don’t have permission on your machine to open a serial port… DFU uses a different USB protocol.

Change to a new post called:
Openmv IDE does not recognize usb
in case someone can help me.

Hi, if you have your OpenMV Cam receipt I’ll give you a refund for your trouble. Just need to see proof of purchase from one of our distributors.

I bought a kit with lcd, test plate and lenses from the website of and the invoice is from MacroFab.Inc of Houston dated 2017-05-15 sender reference 6609. I send you a copy of the invoice by email.
I would like to find a solution to the device reprogramming.
Thanks for the answers and I feel so many questions.
Thank you very much