Openmvide does not recognize internal disk

Follow the topic OpenMV Cam M7micro very hot
With the jumper YES recognize a dfu device, both in Windows and Linux, but if you remove the jumper, it stays blue blinking and does not recognize internal disk. OpenmvIDE I open it as administrator or root.
During the firmware recording, should the led flash ?
It is possible to reprogram the firmware with another application ?
Should bootloader.bin, firmware.bin, and openmv.bin be reprogrammed ?
Help me, please.

I doubt any other forum member knows.

As I’ve said the device functionality seems fine. But, I have no idea what it does not work for you.

I have rescheduled the device with other applications and still the same, it recognizes the DFU mode but not the internal usb device.
It writes perfectly openmv.dfu, so it must be hardware failure on the STM32F765. The led is turned on in white, then on red and led blue flashing.
We will try another openmv cam.
Thank you for your interest and patience.

What are you doing exactly? Can you explain? In detail?

After several days without running (no flash leds) and without being recognized DFU mode, today finally, taking the openmv cam and pressing with the fingers on the USB connector (?), Has recognized the DFU mode.
As I said, with sudo pyhton, list, delete and save the file openmv.dfu, but once removed the jumper no longer communicates with openmv ide and the pc does not recognize the internal usb disk. Only the blue led flashes.
The openmvcam works with sd card. I record the sample file on the sdcard as I put it in openmv and that’s it.
Clearly I can not debug and burn directly because it still does not recognize the internal disk.
Nothing else, I’m waiting for a new openMV because I still believe it is a good product
Thanks for your patience

Mmm, we’ve noticed a firmware issue with the internal disk not being reconginized. I believe we can fix this if we can get an idea of what the problem is. Can you open a bug on the OpenMV GitHub.

… About random issues, your an early adopter buying the camera right now. Sorry about having them.

Reprograming with ST FlashLoader usb-serial
Work with the sdcard but without it the blue led flashes blue.
I go a few days to the mountain because here in Barcelona it is very hot.
See you soon

Note, when you reprogram with the OpenMV.dfu file you should not have the SD card inserted. This will cause issues…

As you can see in the image, there is no sd card inserted.
With the openIDE, the sd card is not inserted either, and not reprogram.
The examples record them on the SD card externally, rename the file and then insert the sdcard into the camera and it works perfectly.
Can it be a compiler problem used for firmware?
Any configuration parameters of the STM32F765VI ARM Cortex M7 processor?

Mysteries of the electronica
Thanks to them, we learn more.
See you soon

Yes, we’ve noticed this issue but are unable to root cause since it happens irregularly. Ibrahim tried to find it but he cannot reproduce. Hopefully updating MP in the future will fix this…

I will be working on fixing this for the next release. This feature did work previously so looking through what code was changed should allow me to find what was broken. For now, please us and SD card to run your program on. The error doesn’t happen with an SD card.