openMV unable to connect arduino nano rp2040 connect board abx00052 / ABX00053

Hi all

i have tried to follow many video YouTubew’s demo to install firmware and upload a micropython file to many arduino nano rp2040 connect boards for many times but failed.

I have tried to do it with Thonny too. after a lot of tests, I believe that it is the problem of the latest firmware problems or openMV. I cannot roll back to the old versions of firmware. Any idea to solve it?


Hi, there’s a version of the RP2040 out there we aren’t able to support. I forgot what the issue was but it was something due to how they were manufactured. If you have a board with this issue it’s not fixable.

I have many pieces of Arduino Nano RP2040 Connect boards. This issue is the same with these boards. I can program them with Arduino IDE but I cant use OpenMV or Thonny to program it.

I have tried the programming files uf2 on the but all are still not successful.
I saw some YouTube videos of demo but they are using the old versions. Where could I download the older version?

Um, I think it has to do with like the particular variant of the chip or the external flash used with the board.

@iabdalkader Would know more on the exact issue but I don’t believe it’s fixable.

Very likely the new version of firmware has problems. I would like to try if I could get some older versions of RP2040 firmware.

That limitation was fixed a very long time ago, I am using MicroPython (both upstream and our firmware) on Nano-RP2040 all the time and the firmware runs fine on it, I tested it as recently as yesterday.