OpenMV Not being detected

Hi,

I have a be openmv h7. My IDE is not able to detect the device. Windows does’nt detect it either as a USB.
I have done the following :

  1. Tried it on Linux, RPi, and Windows.
  2. Tried with multiple USB cables to be sure it wasn’t an issue with the cable.

On boot, the MV starts with green LED Blinking, then White LED Blinks and then stops at Blue LED. It keeps blinking.

regards
Suresh

Sounds like the camera is fine. Are you sure the USB cable you are using supplies data and power? There are a lot of power only USB cables out there.

Thanks for the Reply.

Yes, I am using a right cable. My android phone is detected as a drive on my laptop with the same cable.

Is there any other diagnostic tools i could use to debug whats going on ?

regards
Suresh

Hmm, you don’t get any sounds with Windows or anything else?

The USB pins may not have been soldered right. On the cameras we make we check that they work at the factory…

Try this, on Windows, connect the BOOT0 and 3.3V pin. Then plug into the PC. There should be a device that appears under the device manager (this is a windows admin tool that displays a tree view of everything in the system). Under USB devices you should see an ST DFU device. If that’s not there then there’s a hardware issue with the camera.

Thanks for your reply.

The cable i was using is correct. Apparently the Pin on the Camera module has some loose contact. If i hold the pin tight it works, i am able to detect it on the IDE. But not long enough…
Tried with a few other cables, same result.

rgds
Suresh

Hmm, that’s hardware damage. Can you post a pic?

cant seem to find a way to attach a pic? can i mail it somewhere ?

rgds
Suresh

You just upload it via the Attachments tab next to the options tab.

Hi, so I followed the same instruction from the thread. I found the ST DFU device when it is connected to PC and BOOT and 3.3V is connected. However, the camera sill produces issue where it is not detected. it blink green, then white, then continuously blink blue . Is there a general sure way I can just reset everything ?