New M7 not detected over USB

I bought two M7s one of them seems to be working and the IDE can connect to it and windows recognizes it fine.

The other one isn’t recognized by windows when using the same USB cable. It just says that the USB device isn’t recognized and to try to plug it in again.

Any suggestions?

Mmm, okay, try to put it in DFU mode. If that doesn’t work there’s an issue with the USB connector…

(This is second time we’ve gotten a customer saying the USB connector is bad - for the next OpenMV Cam production run i will require each cam to be plugged into a PC before it passes Q.C. versus it just passing Q.C. with our programming jig…)

To put the camera into DFU mode do this:

And then plug it into your PC and you should see a DFU device (in windows):

If that doesn’t work please send us an email with your shipping address, phone number, and receipt, and we’ll send you a replacement.

Just tested, with the jumper it still says device not recognized but the camera doesn’t flash any of it’s LEDs like it normally does.

K, send us a email with the info above. You might be able to fix the camera by applying a heat gun to the USB connector for a few seconds.

Third one here!

I’ve just received the OpenMV M7 camera and it does not enumerate, both in normal operations and in bootloader mode.

I’m running Ubuntu 16.04 and I work with several STM32 microcontrollers without any problem in enumerating their USB ports, here the dmesg output after I connect the camera:

[1476382.168489] usb 3-4: new full-speed USB device number 75 using xhci_hcd
[1476382.168637] usb 3-4: Device not responding to setup address.
[1476382.372633] usb 3-4: Device not responding to setup address.
[1476382.576473] usb 3-4: device not accepting address 75, error -71
[1476382.576514] usb usb3-port4: unable to enumerate USB device

How should I proceed?

You emailed us. We’ll take care of this from there.

Um, as for a check, can you test the system on a windows machine? If the USB were bad you should see any action right?

I am also facing the same issue

New H7 not mounting on Ubunut 18.04/MAC OSX 10.14/windows 10

Although I see LED light flashing green on connect and then flashing blue but it does not show up on the system.
I tried the following steps mentioned in this thread and still do not see any device under the USB controller on window

Please suggest what should be done?


Please verify that the USB cable provides data also by hooking up your phone or other device through it.

Thanks. Using a data cable worked.

I am also facing the same issue as well!

H7 not mounting on Raspbian 5.4 , Ubunutu 20.04 or Windows 10

I see green led blinking then flashing blue but it does not show up on the system.

Cable works fine.

Nobody have any suggestion? maybe… better to choose anotherone cam.

The camera has power, so it’s either the USB connector on the camera is faulty or the cable doesn’t have provide data, just power. There are a lot of USB power only cables out there now.

Oh damn YES! You are right. I thought I was using the right one … I firmly believed:? :confused: :confused:
anyway i just plugged a good usb-data into my h7 cam and everything looks fine
sorry my bad.