Cannot Connect USB Device


When I try connecting the camera, I get a message saying that the USB Device cannot be recognized. The device does no appear in device manager, under Universal Serial Bus Controllers, it says Unknown USB Device.

The green light blinks a couple times, a white light for a while, a red light blinks once, and then a blue light keeps flickering.

I have tried different power and data micro-usb cables and multiple USB ports so I don’t believe that’s the problem.

I have tried updating the DFU Bootloader; however, it froze at the “Reprogramming… (may take up to 5 minutes)” screen while I waited for 20 minutes.

Any ideas for fixing the problem would be appreicated


The blue light blinking means the camera is running fine. The behavior you’re seeing is consistent with a working camera.

Um, mmm. So, power is obviously making it’s way over the USB cable.

Um, when you put it into DFU mode… Does any STM32 microelectronics device appear under the device manager?

You put the device into DFU mode by attaching a jumper wire between reset and BOOT0 and then plugging he device into the PC. Then, check the device manager.

Dfu programming should have instantly failed if the camera USB connection was bad.

I put the device into DFU mode by attaching a jumper wire between reset and BOOT0.

In Device Manager, it says ‘Unknown USB Device (Device Descriptor Request Failed)’

The reprogramming window continues to hang as previously mentioned

Hi, please send OpenMV your receipt for a replacement.

That’s unfortunate to hear.

What do you think might have caused the camera to stop working?

It is not my OpenMV camera but I will discuss this with my employer tomorrow and ask for a receipt to forward to you for replacement.

Hi, please try it on a different PC. However, I fear the USB traces are damaged. This is usually the cause of failure.


i used regularly openMV camera for some days without any issue.

few hours ago I was testing the examples related to april tags and I noted that find_apriltag was working fine and find_apritag3dpose was not able to find the apriltag. It was very strange since I already test both examples some month ago. I have a doubt that firmware was supposed to be updated and when I try all led on camera switched off like that camera died.

Even when I connect to pc cannot be detected at all.

Camera can be detected by pc only if I connect boot to rst but anyhow leds remains off all times

Any suggestion?

Thanks a lot


In DFU mode the LEDs don’t turn on. Can you follow the IDE prompts to try to recover the firmware? It shouldn’t be bricked.

Note the green bootloader light should blink when you first plug the board in.

No led blink anymore. During first attempt to reinstate the firmware, green led was blinking, now everything looks died.
Only when I plug the camera with jumper between Boot and RST I hear a bip coming from PC. that’s all :frowning: :frowning:

Okay, just follow the DFU update instructions provided by OpenMV IDE and you should be good to go. It works very reliably on windows. To start the un-bricking process click the connect button on the IDE and say my camera is bricked.

I can complete the DFU firmware updated but when I remove the jumper and I’m asked to push ok button once autotesting is completed (blue led blinking) I can’t press OK since blu led never blink. I waited several minutes…

Hi, try unplugging from the PC and plug back in without the jumpers. It may work. Or at least the bootloader should be use our regular firmware update.