Installation error - can not read temporary file - windows

I can not install latest IDE 2.6.5 on windows64 (updated reguraly). Image of error in the attachment:

It says Cannont open temporary file: No error. When you click ok it will roll back the installation. I have default windows defender antivirus which I tried to disable with no succes.

It get stuck on “Creating maintanace tool”. I have previously working IDE - older version, that I have completely uninstalled and restarted PC before installing new IDE. Please advice. Thank you in advance.
Screenshot 2020-11-03 134536.jpg

I have tried this:
once I hit the error during instllation I manully kill the installer from the task manager. This will prevent installation rolling back. Than I connected the camera but it cant connect. So I have slected the camera bricked option and on second attempt erased and reprogram the camera.

Okay, a new IDE release is coming this week. Maybe the issue will be fixed.

I came across the same issue when installing the 2.6.8 on my AMD Ryzen desktop.

Were you able to get past it? I have never run into this issue. I imagine it happens because of permissions on folders.

I did update to new IDE and experienced the same issue. I do not know what is underlying problem but the solution for me was to let it install until it shows error and then simply kill the installation process from task manager. Everything seems to be working ok after this so I consider it solved for the time being. If it persists in new release I will try to debug the dir permissions but I still find it strange as other installers seems to work just fine. On the other hand if it is just me than it might stem from some compatibility issues between programs or drivers. Right now I have working IDE so I am not going to analyse it as long as everything is working.

PS: Thanks for april tags examples! They run great. In the end I am using processing on recieving PC anyway for other reasons but to know I have the possibility to track on camera is neat! I really like OpenMV and appreciate how welcoming supportforum is.

Question, did you uninstall the old IDE first before installing the new one?