Cannot run IDE in Windows or Ubuntu

I received my Kickstarter OpenMV board a couple days ago and I was really excited to try it out. But I’ve been unable to use it because the IDE won’t run. I’ve tried on both Windows 10 and Ubuntu 14.04, using their respective IDE versions from your Downloads page.

On Windows, I unzipped the folder and double-clicked the OpenMV IDE icon. Nothing happens. In Task Manager, I can see that it’s running but no window appears. I’ve tried changing the program compatibility settings but nothing helps it.

On Ubuntu 14.04 LTS, I unzipped the folder and tried double-clicking the openmv-ide icon. Again, nothing happens.

So I went to the Terminal and here’s what it said when I ran it:

bash: ./openmv-ide: cannot execute binary file: Exec format error

Can you please help me get the IDE up and running so I can play with my new OpenMV board?

Or is there a way I can use a different IDE? Of course, the problem with that is how do I see the preview images showing what the camera sees and what it’s recognizing?

Thanks.

That’s odd, we’ve tested it on several windows machines and linux machines.

Okay, I’ll check on what’s wrong with it tonight. Sorry about this.

Um, in the mean time… the IDE is basically a python script. Since you have Ubuntu just follow this guide here to run the IDE: https://github.com/openmv/openmv/wiki/Firmware-Development#linux-installation

Once you have all that stuff installed you can just cd to the openmv usr folder and just execute the python script and it should pop up. When using the openmv repo please make sure to checkout the v1.4 branch.

Hi, I tried the program out on a fresh install of windows 10 and I had no problems. Similarly with a fresh install of Ubuntu 14.

What platform are you using? Getting that binary error means your not on the right architecture. We compiled the program for 32-bit. I’m not sure if that means 64-bit Ubuntu can’t run it. But, maybe you have to install 32-bit libs first. On windows however, this should not be a problem.

I have a laptop with 32-bit Ubuntu (although I did notice that it’s a 64-bit CPU) and Windows 10 on a 64-bit laptop. I’m trying to work through the manual process you suggested of building the IDE but it may take me a few days.

I have the same behavior on Windows 7 Pro (64) and Windows 10 Pro (64). Same Dell Latitude laptop, dual install. On Windows 7, i installed the device driver from the new drive that appears and the .inf file contained on it. The IDE is running - it’s in the process list - but there’s nothing on the screen. Same behavior in both versions of Windows.

Is there any installation for the IDE or does it just run as a single binary in that folder? I have it in a folder on my desktop.

dj

Just found this: https://github.com/openmv/openmv/wiki/Windows-Installation and will work through updating Python and report back.

Hi, you might want to give the IDE a minute or so to load, sometimes it takes time to load.

Those instructions are for manual installation, I use them when packaging the IDE for a release. If you want to try that go ahead, you’ll be able to run the IDE as a Python script which may print some useful info.

It did open eventually. 14 minutes later! What I found after doing some digging is that the Microsoft Anti-Malware process is “chewing” on the IDE process the entire time…taking 25% CPU. I added the process as an exclusion in security essentials and it now comes up in less than 10 seconds.


dj

When we get the new IDE done using QtCreator as the base all these problems will go away. But, don’t expect that to be done until October. Anyway, I hope you enjoy the system. We put quite a lot of work in.

Try out the GIF recording script. It’s so cool.

I’ve just gone through 3 examples and some of the docs. This thing is awesome! Thanks for all of the effort…it really shows.

dj

I know the exe is clean, but just in case I scanned it anyway:

https://www.virustotal.com/en/file/9d72a8da4dd10ec8b249d8b4b334b538f5a6fffa942f3842509cdca729393397/analysis/1464364279/

14 minutes later???! Maybe I wasn’t patient enough. I killed the process after just 2 or 3 minutes.

When I get home from work, I’ll try whitelisting this from any security scanning software and let it take as much time as it needs.

I’ve been super excited about this project for a year. Only to find that I can’t even run the IDE now that I’ve got the hardware.

Thanks for the tip, djmanning!

It shouldn’t/doesn’t take that long. If there’s something in the binary that MS Anti-Malware doesn’t like we’ll fix it in the next release.

I can happily confirm that djmanning’s solution works. In the Windows Task Manager, I can see the “openmv-ide” task way down under “Background processes”. When I double-click the icon, I see it appear there as a task starting out with just 2 or 3 MB of memory but no window appears. I watched as the memory usage slowly increased to 4 then 5 then 6 MB so I realized it was definitely doing something.

Turns out I don’t have Microsoft Anti-Malware on Windows 10 but I do have Windows Defender running. Go down to the option called “Exclusions” and click “Add an exclusion”. Then click “Exclude a file”. Here, you can choose which file you want Windows Defender to ignore. Select the openmv-ide file that you’re trying to run. The instant I did this, I saw the memory usage in the Task Manager jump to 45 MB and a few seconds later… the IDE window appeared!

Thanks again for your help, djmanning and everyone else!

After some digging into this issue, I found out that PyInstaller’s bootloader (the binary that extracts and runs the Python scripts) is used in many Python malware, that’s why antivirus detect it.

See: