problem w/ IDE install

Hi everyone.

I’ve got a problem with the IDE installation when i try to install in Old SO like Windows XP or Windows Vista, the installation just freeze at 66%. (img shared) setupfreeze — ImgBB
Finally when i’d could intall it in Win Vista, IDE shows error when i try to record or play any video file.
Thanks for help!.

I installed the IDE on vista and windows xp. From my own tests, I have not gotten it to run on XP with SP2. As for vista, it should run on that. If it’s failing to install… I don’t know how to help. It would be an issue unrelated to the software.

As for the video record failing… this happens due to the way the IDE launches a terminal window to print the command line output. I’m working on a fix for this in the next IDE release which will come soon. It’s kinda a hit or miss thing right now if it works for you or not. Basically, I try to launch a command window to print the output of a command line application… and sometimes… this doesn’t work due to the various software installs on different machines. It worked on all my test systems so I thought it was good.

Thank you kwagyeman for the answer.

Ive installed ubuntu 12 on same laptop i tried with windows vista. i could run IDE and connect the camera with no problem but i cannot record from IDE (the problem seems to be in the file saving cuz it let me choose the route where i want to save after i stop the recording but it wont save it at all). Otherwise if i run video recording examples, i reset the camera and theres no file recorded on the sd. I understand this is part of the problem you told me, cuz i tried it on another computer and it works perfectly. Hope you fix this asap. Sry for my english, not my native lenguage and Ty for helping.

Hi, this is an issue with how the terminal launching works and will be fixed for the next IDE release. It’s related to command line arguments to being passed to the right command line program.

Essentially, I call a program called ”terminal_emulator” and I pass it the argument to run the video converter program along with the file paths. The terminal emulator is supposed to pass the remaining arguments to the command line program but instead parses them for itself and then exits due to the arguments not being expected.

The fix is to use multiple levels of argument quoting.

What is annoying is that this behavior changes on what version of desktop manager you use. So, I thought I had it right initial.