IDE Install failing on OSX Catalina

I get the following message when I try and run the app after I copy it to Applications from the Disk Image:

“OpenMV” is damaged and can’t be opened. You should eject the disk image.

Anyone have a fix?

thank you.

I solved it by running

xattr -cr /Applications/OpenMV\

This clears some flags and allows it to run - however I believe the app packaging is fundamentally broken, I should not need to run this.

Can you let me know if this package has issues?

I didn’t change the process by which the app is packaged.

I’ll do a full rebuild and see if that fixes it.

Have same issue. Suggested solution works.

Hi, I’m going to do another release. In the mean-time:

Tried removing the 2.5.0 and installing this. Got a pop-up saying it cannot be opened because Apple cannot check the file against viruses etc.

I just had another user say it was fine. It’s digitally signed however.

Which part had the popup? The dmg or the app? The app should be signed with codesign.

the app. the dmg opened fine. The xattr workaround suggested above worked this time as well.

Ah, you shouldn’t have to do the work around with 2.5.1. maybe doing that broke the code sign.

I had another user just use the app directly without any work arounds and it worked.

I HAD TO do the workaround with 2.5.1: At first, without re-applying the xattr workaround, it did not open but showed the popup as I described. It ONLY opened after I did the workaround again.

But it is of course possible that the first time I applied the workaround is somehow affecting the new install despite me removing the app in between installs. I don’t see how, but I digress…