Strange behavior in the IDE.

Hello, I am trying to use the OpenMV IDE on MacOS, at first everything was correct but for some reason I do not know it will not let me enter the examples, always show a new version of IDE and it will not allow me to update the firmware of the camera. I have tried to download the IDE again and reinstall it, but it does not work.

I attach some images so they can see what happens.


I just saw this too and notified Kwabena. We’ve just switched servers and It’s probably related. I think you can ignore that update message, just click cancel.

Thanks for the quick reply.
I checked if the examples in the “app” are the examples and if they appear, also the firmware appears, it is as if the application did not have access to the resources.

I check in Windows and i have exactly the same error.

We just switched servers. Will debug. The IDE is likely getting an error page and parsing it like a valid response.

The management on the site side is strange
You can also understand major version suddenly from big things
If you just download and install it, there is no problem
After that, updating documents and examples seems to be strange
Although it seems that writing method of installation process is bad and you want to erase all existing data and then try to write
I tried to set up a 4.3.0 document or sample even though the original version is 1.7.1
Because there is no data, it can not be installed and it ends and all samples and document setting relationships disappear
I will not be able to do anything
The data to be managed is under / users / (login User name) /. Config / OpenMv
The files are OPenMVIDE.db, OpenMVIDE.ini, qtcreator
qtcreator is a directory
Documents and samples are placed under this directory
The problem of erasing under this directory is a problem, and to be unfavorable / users / (login User Name) /.Config / OpenMv
If the OpenMv directory exists for, it will not be created even if you copy the IDE to the App directory and restart it
It will not move
Obviously a program mistake. It is a fatal bug that you can not recover if you set a version that does not exist
To restore this, if it only knows the cause, it is simple, erases all file directories under the OpenMv directory
If you also delete the OpenMv directory and set up the IDE, the IDE program will generate it yourself again
After this, at 4.3.0 it is obviously not upgrading with funny version, upgrading like 1.7.1-> 1.7.2 and
Let’s upgrade the version when there is an official announcement of the site

I thought that a considerable number of people were affected, so I mentioned the recovery method
I hope you find it useful

It is troubled.

:nerd: :nerd: :nerd: :nerd:

I checked Windows, too
This seems to make the file invisible in the same way
Recovery is easy and after installation
Just install it again and do not update the document or sample
It’s easier than mac

We look forward to helping you
:wink: :wink: :wink:

Hi, the issue is fixed. The version 4.3.0 was coming from an error page the IDE was parsing. I’ll make the parsing error handling better for v1.8.0.

As for if you accidentally upagraded… delete you “AppData/Romaing/OpenMV IDE” settings folder… or on mac/linux “.config/OpenMV IDE”. OpenMV IDE will then reload the default settings.

There are still some issues with getting cloudfare running again. But, I think basic website stuff is working.

I still will try to move things off the webserver in the future. I don’t want this happening again. We still don’t know why the previous server228 had issues.