Fried SD Ram? H7 Plus Brick

This is the 3rd camera that I have fried and I can’t quite figure out what I am doing that is breaking it. I’ll describe the issue first and then talk about how it got to that point. Before then I will put my primary questions in the beginning so you don’t have to read my problem in depth if it’s not necesary. Is there a specific protocol for handling the H7Plus when using both USB and 5V Power Supply connections? Have you ran into issues with having them both plugged in at once and then unplugging one and plugging it back in? Should I always program the camera not connected to 5V PS? I would love some help even if I can’t fix these camera just so I don’t break anymore. To me it almost seems random when the get fried like this.

Problem and Initial Troubleshooting: When I plug the H7Plus in either with 5V Power Supply or USB it flashes green for a couple seconds followed by a single white flash. After that no lights show. When I try to connect it to the IDE it cannot find it. If I go through the prompts to Flash the H7 Plus Firmware and it flashes green during the entire erasure/programming process which takes ~2 minutes. After it programs the screen comes up saying that it is running its self test and to wait. During this time no LED’s flash at all and I waited 20+ minutes because it did say that it would take a while to no avail. I repeated this both with and without and SD card as well as with and without erasure. If I hit cancel to skip to DFU Programming and follow the instructions by jumping the BOOT and RST pins. When I reconnect the H7+ to the computer after jumping the pins no leds flash. I waited 5 minutes to see if the Bootloader has “enumerated” to no avail. The command "DFU-UTIL terminated with exit code 74. I have tried this process connected to USB at first then connected to USB and 5V PS. From reading some other threads with similar issues it seems as if there is a physical problem with the SD Ram. The only advice in the other forum was that he Uploaded the H7 Firmware onto the board and got it to work. I have NOT tried this yet as the forum post advised not to. That is the problem and I want to confirm that my camera is fried and not recoverable? Should I try the H7 Firmware since it’s fried anyway?

How I got into this problem:
Everything was working fine with my H7 Plus, it was plugged into 5V PS and USB and I was watching my program run perfectly fine. I then turned the PS off leaving it connected to USB. When I next turned 5V power back on, the IDE asked my to update firmware of the device. During the update firmware process the board shut down due to what I assume was some sort of electrical overload. I turned off the PS and unplugged the USB connection. I then tried plugging in the USB and the 5V PS separately and also together with no LEDs flashing or connection established. I waited 5 minutes with it unplugged and plugged USB in and I got green lights to flash for a couple seconds followed by the white flash. This is the current state of 3 of my H7 Plus’s that I have. The other two had a similar fate.

Possible Causes:
My best Idea that I can think of is that when I power on the Camera with USB and 5V, The camera on startup chooses to ignore one and use the other. Then when I power off the 5V for example and power it back on, the camera doesn’t recognize it and when it tries to program the firmware the 2 voltage sources cause some sort of overload. If this is the case what can I do to prevent this from happening? My camera is hard wired into another machine so I need to power the rest of my machine in order to test my code which also powers the camera. If you have some other idea of what might be going wrong that would be great. I really appreciate the help.

Haven’t read through all of the post, but it would be very helpful if you upload pics of the cameras showing how you connect the 5V etc…

NOTE: With an SD card connected the camera doesn’t run the selftest or (which blinks the blue LED), these scripts are created on a fresh internal storage filesystem.

It’s not broken. It’s not possible to break the camera in the way that you did. The VIN and USB have logic to handle both being powered at the same time.

As for the blue flashing LED. Please realize that this only happens if you didn’t modify the script from the default one that comes with the camera. If you have a new written with your code or have one on the SD card then the camera runs that instead.

So… did you put any code on the board that uses low power sleep modes? If so, you need to select the Erase Flash Drive option when loading new firmware. To reload the board:

  1. Unplug the camera from your PC and 5V power supply.
  2. Click connect on the IDE.
  3. Follow bricked prompts.
  4. Plug the camera in when requested.
  5. It should load the firmware if the green light was flashing when it was plugged in.
  6. Do not use DFU mode… with the H7 Plus ST broke the normal DFU loader. It’s only possible to load the bootloader via DFU and not the entire firmware anymore. You can do this manually using the Tools->Run bootloader option and selecting the openmv4p/bootloader.dfu file. However, if the green light is flashing on the camera on plug in then it’s fine. You don’t need to re-flash the bootloader.