Flashing Green, then white once, then dead... bricked?

I updated my IDE today, and plugged in my H7 device. The IDE did not recognize it. I have tried several USB cables and the same thing happens. As soon as I plug the device in I get a fast blinking green immediately followed by a flash of white, then nothing… I have tried to refresh and recover the firmware as the IDE suggests, even bridged the rst and boot pins as suggested, to no avail.

Is there some who can help me understand next steps? I noticed there is a micro sd card slot on this device, mine is empty, I can’t recall if I need one or not?

The flashing green led is the bootloader and the flashing white led is the firmware on the board panicking because there’s a hardware failure.

Since the bootloader is still fine you can reprogram the board using the ide by just clicking connect while the board is not connected to the ide and following the prompts.

Also, where did you buy the board from? Does it have a we qrcode barcode on the back of it?

thanks @kwagyeman! I did buy the device from you directly, yes it does have a QR code on the back.

Can you elaborate on what “reprogramming” the board entails? I am curious if there should be any lights that flash during the process? I have walked through the process in the IDE several times, I reach the part where it says it may take up to 5 minutes and have left it there for 10 or 15 minutes several times but during the whole process the device is dark and it appears as though nothing is happening. I end up having to kill the IDE in order to try again.

Hi, if the bootloader is running on the camera then the green light flashes. You should not have the wire connected to the BOOT0/RST pins.

So, there are two ways to load firmware on the camera:

  1. Our bootloader
  2. DFU which is built-into the chip itself.

Our bootloader runs on power on, flashes the green light, waits for the IDE to connect for like 5 seconds, and then runs the main firmware (only when powered via USB, otherwise it runs the program immediately). The IDE prompt when you click connect and the board is not connected is designed to connect to our bootloader.

If our bootloader is corrupted the only way to recover the camera is via SWD/JTAG which you need a programmer for or DFU. DFU can only be activated by shorting RST and BOOT0. DFU allows you to erase and reprogram the bootloader and main firmware… but, it’s quite slow.

DFU should only be used if the main firmware bootloader is dead. So, can you confirm that when you connect the device to your PC that the green light on it flashes on startup when plugged in? Without RST/BOOT0 shorted?

Yes, I can confirm when the device is first plugged in, it will give 7 or 8 very rapid greed pulses immediately followed a white pulse, and then dark… once the sequence is complete the device stays dark indefinitely.

That’s the normal operating procedure. It goes dark because it’s running a script onboard.

What script did you put on it? You may have a script onboard that blocks USB access or causes the camera firmware to crash. In this case please select the option with the bootloader to erase the internal upy disk.

Do you have an sdcard connected ? If so the camera will not find main.py and will just wait for the IDE to connect.