Cannot open python script from openmv filesystem

Hello, i’m currently facing an issue where when i connect my usb c cable to my RT1062, it is detected (as seen from my device manager) and the file explorer window pops up and shows me the contents inside my openmv filesystem.

However, when i try to open the script as a text file, the text editor pops up but hangs. When i press connect on the openmv ide, this window is seen:
image

I previously tried to power the openmv board through the vin and i also connected my usb c cable to the board, after which the above-mentioned issues were seen.

Did i damage my board by powering it through both the vin and usb c port?

No, it has protection for that. There’s an ideal diode.

So, unplugging it and replugging it did not solve the issue? Can you unplug and replug it and then click connect without trying to open the file on the disk? If it hangs there… then the only thing I can think of is that the script is causing a bug to be hit in the firmware.

If you just connect the SBL to 3.3V and then plug into the PC you can reflash the board which will reset any onboard script if you select the erase drive option when following the dialogs.

Yes unplugging and replugging it did not solve the issue. I tried clicking connect again without trying to open the file on the disk and the same connecting window appears and it just stays there.

I also noticed that after awhile this windows notification is observed
image

I will try to reflash the board and will update again here shortly

Ok i have tried to reflash the firmware as advised but i am now facing another issue.

After plugging in my usb cable and hitting connect on the IDE, this window pops-up
image

I check the “erase internal file system” checkbox and proceed with the reflashing of the firmware.

This window pops-up
image

However, after pressing ok, this same window pops-up
image

My SBL is still connected to my 3.3v at this point, should it stay connected throughout the flashing process? Or should i disconnect it?

You need to remove that wire. It forces the board into it’s recovery mode. After you finish updating you don’t need it anymore.

I’ll update the dialog for the RT1060 to mention that.

Ok got it, it is working now thanks!

Hi, if it breaks again please try to replay the issue so we can distill down if it’s a bug and fix it.

Ok will do

Hi @kwagyeman, the same issue happened once more, but this time it happened only once and it was after i connected a tv shield to my board. Managed to re-flash the firmware successfully.

Here’s where i noticed something else, i saved the example tv.py code into my board and whenever i provide power into the vin when my board is already connected via usb (and vice versa, board is powered via the vin and i plug in my usb cable), the program hangs (i have a video screen that can view the transmitted video feed via the tv shield) and the video feed becomes very wavy and distorted. after disconnecting one power source, the video instantly loses the distortion but freezes.

not sure if this will be useful but just letting you know about this!

Hi, that’s the ideal diode switching over. However, I’ve tested it extensively and debugged it such that the power rail to the processor should not collapse during switch over. The system should be capable of handling 200mA without issue. I.e the regular system draw.

Maybe your VIN sags when there’s a current demand…

Anyway, you can fix by adding a battery. Any JST battery attached will act as a cap to handle when switching between power supplies. The problem will go away.

Oh! Okay, so, VIN need to be 0.5V higher than 5V for USB. If they are the same the ideal diode freaks out. E.g. if both are 5V you get weird behavior. Raising the value of VIN should also fix this. Otherwise, just attach a bettery. Once you have a battery attached you can go up into the 1A or more current draw range and not have issues switching between supplies.

Ahh i see, my VIN is about the same if not slightly lesser than the USB 5V which explains the behavior. WIll try it out again by raising either the VIN voltage or by connecting a battery to the JST connector, thanks!