Camera output is green and purple

I’m using an OpenMV H7, and I’ve encountered this problem where the output from the camera is all green and purple. According to the LAB colour space, the colour is inputted into the IDE as green, so I think there’s something wrong with the camera lens. Any suggestions?

Hi, it’s the firmware on your board. You likely have the H7 firmware running in the H7 Plus.

You can fix buy manually installing the latest firmware from our release page using the Tools → run bootloader dialog in the ide.

The firmware to load is the OPENMV4P/firmware.bin file.

Thanks for the reply!

I did exactly as told. I downloaded and opened the zip file, ran the bootloader, and got the message that it was installed. However, nothing has seemed to change and the output is still green and purple. Any ideas on what I did wrong?

Send us a pic of the camera so we know which board you have, and a screenshot of the terminal output after you stop the script.

Here are the camera and the screenshot

You have the wrong firmware, it should say OPENMV4P-STM32H743 note 4P not 4.

Where can I find the firmware?

Use the Tools->Run Bootloader

To load the openmv4p/firmware.bin file.

So I installed the firmware, but then it says that no camera was found, so I reconnected it, but then the firmware remains as 4 instead of 4P, even though I’ve clearly installed 4P. What should I do?

It’s not possible for this to happen… what occurred when you installed the firmware? Do you have another OpenMV Cam attached?

I don’t have another camera connected. It’s just one camera.
I go “Run Bootloader”, select the 4P/firmware.bin file, and run it. Then it says that no camera was detected, even though I have the camera connected.

Unconnect the camera then plug it in again. There should be a green light flashing.

If there’s no green light use the bootloder.dfu file to restore the bootloader and then try the firmware.bin afterwards.

I tried disconnecting times, but sometimes there would be a green light, sometimes there wouldn’t :confused: When there wasn’t a green light, used the bootloader.dfu file, but didn’t work.

I also want an update to this thread.
Can somebody provide any advice?
Thank you very much.

Please follow these instructions literally:

  • Disconnect the camera from PC (keep it disconnected).

  • Start the IDE and hit the connect button (or Ctrl+E). You’ll see the following dialogs:

No OpenMV cams found → Ok

Do you have an OpenMV cam connected and it is bricked ? → Yes

Please select the board type → OpenMV Cam H7 Plus (STM32H743 w/ SDRAM)

Erase the internal file system? → Yes

Disconnect your openMV and then reconnect it… Hit cancel to skip to DFU programming → DON’T cancel this dialog, just connect the camera to PC and it should start erasing and loading the new firmware.

Here’s a gif:


1 Like

Thank you very much! This worked like a treat. I’m really grateful for all the responses that have been provided. I’m sorry for bothering you when you were really busy.