Camera doesn't turn on anymore

Hi there,
I was testing my OpenMV H7 Plus today when I left it for a bit and now it doesn’t seem to turn on. When I plug it into my computer or a separate battery, the LED doesn’t light up and it doesn’t look like the camera is getting any power (I checked with an LED on pin 3.3V).
Any idea what’s happening and how to fix it?

Hi, does the green light flash when you plug it into your PC via USB? Or no? If not then can you plug the RST and BOOT0 connector to each other and then try again and see if it comes up via DFU?

The light doesn’t flash when I plug in the camera, I’ve tried DFU with the jumper wire but it doesn’t seem to make any difference.

It won’t flash in DFU mode. It will just appear under the devices in windows as an STM DFU device.

I have tried different cables and wiggled them a bit, but even after following the DFU mode steps it never seems to show up under USB devices in the device manager.

Is the 3.3V rail 3.3V? There’s a 3.3V pin which should be at 3.3V. Please verify that.

I’m only getting 0.28V on the 3.3V pin. I also checked the power supply on the camera side, and voltage seems to increase little by little when I keep the camera plugged in. Really not sure what’s happening here.
Guess it’s a hardware issue.

Hmmm, well, that will definitely cause the processor not to boot. Not sure which piece failed. It’s probably possible to fix still by probing until you find the issue part. I can advise what to do when you find it.

Does the USB port on your computer go into overcurrent mode?

Looking at the schematic (1/30/2022), U4 (PAM2304) generates 3V3 on pin 4 (Vcc) but that will depend on its input voltage on Pin 1 (RAW),
Check pin 1 and note the voltage, this should be close to +5V.
Q2 switches power through to U4 if USB powered, or bypassed if powered via Vin on X4.
U3 seems to be an LDO specifically for the sensor, and it needs 3V3 (Vcc) to operate. If input 5V on U4 is okay, it could be U3 pulling U4 output low, but I would expect some heat.

The next version of the OpenMV Cam shouldn’t have these types of issues anymore. I am aware that users kill their OpenMV Cam’s randomly. The only thing I can guess is that it’s because of static shock. For the next version of the system we are upgrading things to be much more professional and adding lots of ESD protection on all inputs.

(post deleted by author)

So actually I noticed that when I plug in the camera, the processor indeed heats up like crazy. I can’t even touch it anymore after 3 seconds, when it used to stay relatively cool even after minutes. The computer does go into overcurrent mode at some point. I hope that can help you find the issue.

It’s probably broken then. Not sure what failed.