WiFi Shield faulty


I have a problem to connect to the WiFi shield of my “OpenMV Cam H7 Plus” module.
In short:

  • It generates the IDE popup: “OSError: failed to init WINC1500 module”, when using any of the basic examples of the IDE.
  • I have reflowed the pins of the H7 camera module to ensure a connection.
As a sidenote; or where I came from...

I want to run the code of this repository:
OpenMV-Astrophotography-Gear/Polar-Scope-Instructions.md at master · frank26080115/OpenMV-Astrophotography-Gear · GitHub
I am able to install everything. When powering up, the LED:

  • flashes green a couple of times
  • then one white flash
  • after that there’s a loop of flashing red and then green.
    When connected to the IDE the terminal also states some WiFi issues. Unfortonately I’m not physically near the H7 module right now and can’t remember the exact output. I can porvide the output later, when needed. However, I guess this is not relevant, as the issue is, in principle, caused by the connection problem mentioned before.

Am I hit by a hardware failure or could this be on software site?


Did you do the firmware update for the board? Please see the firmware update example script. It has instructions to update the winc1500.

Thank you for your reply. I haven’t updated the firmware. I will give this a try later this evening. Before I do so: Is it save to only update the WiFi shield firmware?
I don’t want to run into any firmware mismatches between the H7 board and the WiFi shield, as the linked github repository stated to use a specific firmware. I have flashed the referenced one via the IDE and don’t see a OSError, as mentioned in this thread.

Hi, there’s a firmware update script in the examples folder for the WiFi shield. Please follow it.

Hi I just ran the script, and got prompted with another OSError. The terminal output is:

Running in Firmware Upgrade mode...
Erasing flash...
Programming firmware image...
burn_firmware: write error!

Traceback (most recent call last):
File "<stdin>", line 19, in <module>
OSError: Failed to write the firmware!
MicroPython: v1.13-r69-dirty OpenMV: v3.9.3-dirty HAL: v1.9.0 BOARD: OPENMV4P-STM32H743
Type "help()" for more information.

The IDE states the OpenVM H7 Pro module to have the latest firmware: 3.9.3

@iabdalkader Please help

Looks like a hardware issue in the WiFi shield, cam or both, there’s nothing I can do these scripts only fail if the cam can’t communicate with the shield for some reason. I’d double check the pins, and note if there is a mismatch between the host driver and winc firmware you’re still able to read the firmware version and upgrade the fw if needed.

unfortunately I don’t have a multimeter at my hand, so can’t test the pins individually. I have reapplied some heat to the pins. So I have already reflowed the sata twice by now. This time I ensured to give the pins each 5-10 seconds of heat. The status remains as is.

Cam firmware is: 3.9.3
WiFi firmware: cannot check

This likely damaged something if it wasn’t damaged before, can you attach some photos of the shield, cam and the shield connected ?

Here you are. The WiFi shield is untouched, as it came preassembled. I hope the pin’s have been checked at factory. I don’t get why this wasn’t the case for the H7 board, but that’s not the scope of this thread.
I tried my best to get you a mostyl unbiased shot of the sata joints on the H7 board. However I can’t clean the flux, which also explains the funny reflection on the 4 right pins in the last photo.

I can’t see a cooked board if this was your intend to let me shoot the photos. I have always applied heat to the pin from the outside (nearest board edge) and let the sata flow from the ‘inside’. As a consequence no trace had direct heat applied.

Edit: I might want to add at this point, that I will oppose to apply another batch of heat to the board if there is no good valid point to do so.

No they don’t check them, as far as I know. The extra flux shouldn’t be an issue now, but later it will collect dust…The solder looks okay from the photos, but there might be a short between the pins, applying more heat is not useful, you need a multimeter to test this.

Do you have another shield to test with ? or another board to test the shield with ? we need to rule out one of them.

No sorry these are my only samples. I have organized myself a multimeter by now. And was about to do what you just suggested. I still have some questions before I start:

  • How can I check the pins of the WiFi shiled? Shoud each one match one of the WiFi chip?
  • Are there dead pins on the WiFi shield, as some do not seem to have traces?
  • I have no clue how to check validity of the H7 board joints except for no short between them. Is there a scematic that shows matching testpoints on the H7 board?

Just check for shorts between every pair of pins (with the continuity test), you can also check the connections between the pins and the modules, and yes not all the pins are used, see the pinout:

There are no test points for the GPIO pins.

Thanks for sticking with me. I have found no shorts. But pin P3 (SPI Chip Select) seems to have no Chip connection. Am I right that it should have a connection to two sata pads of the WiFi chip? To be precise: on your diagram, left side, both of the lowest pads. Would it be wise to heat this one up for a few sec?

P3 must be connected straight to the 4th pad of the module (counting from the lower left side) it’s right in front of the pad. I’d use a soldering iron to fix it, not heat.

I just tested P3 again before using the iron. It has an connection, at least to the pad. Maybe I jumped this pad as is sweeped over the pads before, to speed up testing.
So I guess there’s no way for me to test the validity of the H7 board?

Not an easy way no. There’s one more test you can do, connect the shield and test the connections between the pins on the back of the cam and the pads of the module, the issue could be in the header itself. Otherwise, we can send a replacement WiFi shield.

Thanks for your suggestion, they have a connection. A replacement WiFi shield would be nice. How do we know that the problem is based on the WiFi shield only and how do you send the replacement.

We don’t know for sure but it’s likely the shield, best we can do right now is send you another one.

Order one from the store and send us an email to openmv@openmv.io or leave a note on the order and we’ll refund you @kwagyeman

Thanks a lot for your time. I will test it with a new WiFi shield then and come back to this thread in case it has not solved the problem.

As I am located in Germany and I have originally ordered from https://www.antratek.com/ , which are listed as your repsective distributors. Can I order from them as well and get a refund in the same way?