WiFi connection using WiFi shield

Hello! I’m trying to use WiFi shield to remote debugging my OpenMV4 H7 Plus. It works on Windows 10 system, but cannot work on Windows 11. I have turned off all the firewalls on my PC, but still cannot establish connection to IDE. What shall I do?

Hi, the feature works on Windows 11 PCs. Something must be blocking the traffic. I see from the wifi symbol logo that you PC is getting the camera broadcast packets. So, given this, it means the outbound connection is breaking.

Yes, I suspect that the Windows Defender has broken this connection, so I turned off all firewalls. But it didn’t work. What else can I do?

I’d try out wireshark and look for packets going back and forth between the camera and your PC. You should be able to see the camera broadcast packet being sent once a second. When you click connect on the PC side, you should see the IDE trying to connect to the camera.

If you give me a filtered list of transactions, I can try to debug. However, you need to filter the list to just your PC talking to the camera. Ask ChatGPT how to write the wireshark filter if you don’t know how to.

Thanks for your advice. I used wireshark on win10 and win11 to catch packet.
When connecting to win10, I can see UDP segments and TCP segments (especially three-way handshake segments), shown in fig.1. But when connecting to win11, I can only see UDP segments. Even the camera finish its connection to win10, I cannot see any TCP segments on win11. Dose my firewall block all TCP segments from camera?

Oh, I now understand what’s wrong. It is because of clash verge. When I turned off it, the TCP segments from this port will not be proxy, and I can see them on wireshark. Connection is also right now on win11. I think this may help other people who has the same problem.