OpenMV IDE not connecting to wifi shield after IDE/firmware upgrade

I have an OpenMV H7 with a wifi shield that I have been using for several months. I frequently use wifi to connect the camera to the OpenMV IDE. Last week, I got a new computer and installed the latest version of the OpenMV IDE (2.9.2). At the same time, I upgraded the firmware on the OpenMV board when the IDE asked to upgrade it. The current firmware installed on the board is 4.3.1.

After making these updates, I can no longer connect to the IDE via wifi. However, some aspects of the wifi connection still work, such as:

  1. connect.py example program successfully connects to my network and gets an IP address.
  2. mpeg_streamer.py works, and I can see the camera view when I connect my browser to port 8080 on the correct IP address.

My first thought was to update the firmware on the wifi shield. I followed the procedure to install 19.7.6 using fw_update.py, and the script tells me that all tasks completed successfully. However, if I print the firmware version of the wifi shield, I still get the old version. Here is the code I’m running:

wlan = network.WINC(mode=network.WINC.MODE_FIRMWARE)
print("\nFirmware version:", wlan.fw_version())
# For ATWINC1500-MR210PB only.
wlan.fw_update(“winc_19_7_6.bin”)
print("\nFirmware version:", wlan.fw_version())

Output:
Running in Firmware Upgrade mode…
Firmware version: (0, 0, 0, 19, 6, 1, 0)
Erasing flash…
Programming firmware image…
Verifying firmware image…
All task completed successfully.
Firmware version: (0, 0, 0, 19, 6, 1, 0)

Despite the confirmation message, it appears that the upgrade is not happening. I rebooted from the IDE afterward, but the version still did not update. I suspect this is causing my inability to connect to the IDE over wifi, but I also updated the IDE version when I got my new computer, so that could be a culprit as well. Please advise me on how I can get the wifi connection to the IDE working again. Thanks!

Update: The OpenMV is now connecting to the IDE via wifi. I had to open up the Firewall settings for the OpenMV IDE. However, the wifi shield firmware update is still showing the old version as described previously. This does not appear to be affecting functionality, but I do not believe that I am running the latest version of the wifi shield firmware.

Is everything working?

Yes, everything is working for me. The firmware version still reports itself as 19.6.1 even though I loaded 19.7.6, so I am still not sure which version of the firmware I am running. I don’t know if the firmware update failed (despite reporting success) or if the version number being reported is incorrect. But it is not keeping me from working on my tasks. Thanks for your response!