The board is turned off and does not work

Hi! I recently bought an OpenMV board. Connected the stepper motor driver to OpenMV, connected to Openmw from a computer, it worked, but soon turned off and no longer works. Connected p0-p3 on Openmw to I N 1-I N 4 on the driver (driver image in attachment), connected GND pin with “-” driver power supply (5VDC). Why is OpenMV board not enabled? What did I do wrong? Can I check something or try to fix it?

What doesn’t work? The OpenMV can?

I’m connecting OpenMV to the PC and happens nothing: no LED indication, PC doesn’t see OpenMV device, no signs of life.

Not even the green light? Okay… what voltages were you plugging into the thing.

Unfortunately even no green light( I didn’t use supply voltage for OpenMV, just USB.

did you try another usb port?
did you try powering cam from 5v pin?
Did you try another pc or any usb output adapter?

This thing doesn’t sink much current on inputs.

Yes, Yes, Yes.
It means that OpenMV’s inputs can’t be used with this driver or that i connected driver wrong? Maybe i can check some components on OpenMV board?

Do you have any suggestions?

How did you drive the motor? You might have killed the MCU.

I used pins 0-3 as output and connected them to the driver’s pins IN1-IN4. What I did wrong? I need to know for the future.

Nothing, what was the voltage however on the driver pins? The camera is 5V tolerant.

Supply voltage for driver was 5 VDC nominal (I measured real voltage is 5,5 VDC) and was connected to the pins “+” and “-” (see the picture in first mesage). On the inputs pins of the driver (IN1-IN 4) which was connected to the OpenMV is 0 VDC

so what do you think?

I don’t know. That doesn’t sound like a problem. What voltage did you expose on VIN?

I have good news: I tried to connect the power supply voltage (DC5V) to the VIN and GND pins, and OpenMV turned on (before that I tried to use only the power connector and USB), then I connected it via USB to the PC, and it works! It’s a miracle) Why do you think this happened?

It means the USB VBUS power pin broke. If you were tweaking the cable then this could be the cause.