Is my OpenMV H7 dead?


I ordered an OpenMV H7 from Adafruit. I am pretty sure it showed up dead. Right out of the box I don’t get any status LED when I plug it in. Windows doesn’t react either. I’m using an Amazon Basics micro-USB. Amazon states that it will transfer data and I have used it to power my Raspberry Pi so I am confident we can rule out the USB cable as the culprit.

I have also tried to reprogram the firmware in the OpenMV IDE DFU several times but it just goes on forever. I left it for a half hour 3 times now and nothing ever happens. Is there something I am missing here or can we say that this is a hardware fault? Any assistance is appreciated.


P.S. I tried messaging Adafruit first and they requested that I run this by you before I get a replacement authorized. Here’s the forum link: OpenMV DOA - adafruit industries

Not necessarily, most of these Amazon basics cables are power only (even if they say data), please try another USB cable that you know for sure works for data. If the cam still doesn’t work it may be bricked, you can recover it with DFU, you need to short the boot and reset pin, then connect the USB cable (something should be detected at this point, should say it’s an ST board) and then run the IDE, try to connect, it will ask if it’s bricked, say yes and follow the procedure. Every single camera is tested after production, but in the unlikely case that we missed one we’ll replace it for you.

Hi, at minimum the green boot led should blink right out of the box when it gets power. All cams are tested before being shipped to customers. It is very unlikely it is dead out the box. However, if this is the case we will replace it for free.

Thank you for your help. I’ve tried two cables from two different manufacturers now (both of which are advertised to transmit data) and the reaction is the same. I understand needing to test with another microUSB device but the issue is I don’t own any other microUSB devices (besides my Raspberry Pi but the microUSB port on that doesn’t transfer data as far as I’m aware). I have a friend that has an old phone that uses microUSB so I’ll try with that tomorrow afternoon and report back.

Assuming the cable is working, however, I have attempted recovery with DFU. As instructed I jumped the boot and reset pins but nothing happened. I have attached a picture of my device manager with the OpenMV connected while the pins are jumped. I don’t see anything referring to an ST board but I may be looking in the wrong place.

Next, I opened IDE and attempted to connect to the OpenMV. Followed the procedure to reprogram with DFU. I made it to this screen:

I have let this process go for up to 30 minutes and never observed any change.

I understand that this may all be invalidated if my microUSB can’t connect to my friends phone tomorrow but I am fairly confident the cable itself is functional. I’ll report back what happens. Once again, thank you for your time. I really appreciate it :slight_smile:

From the looks of things it looks like the camera is dead. Let me know whY you find tommorow. We will replace the camera for free if it’s dead.

That said, China is shutdown right now due to the coronavirus. So, for faster shipping, reorder a new camera from Adafruit and send us the receipt if you find your camera is dead.

Finally was able to grab the phone from my friend. Used the same Amazon Basics MicroUSB. Windows found the phone.

Here’s another pic of it plugged in.

Hopefully this is enough to confirm a hardware fault on the OpenMV. I’ll link the Adafruit people back to this thread. Hopefully they can issue a replacement without me needing to put up more money. Thanks again for your help!

Hi, we will replace the OpenMV Cam for you. Please email us your contact info.

I sent you a PM