RuntimeError: Sensor control failed. in Portenta H7 + Portenta Vision Shield - Ethernet

Hello, I run in Portenta H7 + Portenta Vision Shield - Ethernet.
But the error “RuntimeError: Sensor control failed”occurs.

Please refer to the attached image for my environment.

For your information, I also try Edge Impulse with reference to the following.

I can get the camera image. So I suppose it is not a hardware problem.

Please let me know if you have any solution. Thanks.

Hi, the frame buffer is disable on the top right side. You need to uncheck the disabled button.

As for sensor control failed… script looks right. Question, does you camera have some soft foam or etc. behind it?

The first version of these shields have a shorting issue where the camera backplate could short to the pads on the board. You might see a burn mark on the camera if this happened.

Hi, I don’t really know why, but the image is now displayed. I’d like to see how this goes for a while.

Thank you.

Do you have any idea how it was fixed?

In the end, it returned to the original state.
The error “RuntimeError: Sensor control failed” occurs again.
So far no solution found.

Hi, there’s another post about this here: Portenta H7 + Portenta Vision Shield - Ethernet. RuntimeError: Sensor control failed. No HW issue! - Arduino Boards - OpenMV Forums


Tnank you for the new firmware. But still unstable.
Just after the new firmware was installed, it worked well.
But after a while the sensor turned to be unrecognized.

Okay, I’ll do some more debugging.

Hey everyone,

I consistently face the same issue whenever I disconnect the Portenta H7 entirely from the PC.

Although the problem gets resolved, and the camera functions properly when I ‘install the latest development release,’ once I disconnect it, we’re back to square one. Specifically, I encounter the error message ‘RuntimeError: Sensor control failedonly when running a code that involves a sensor. Interestingly, manipulating the LED on the board works perfectly fine.
Perhaps this information could assist with debugging. @kwagyeman

Thanks for the information. It sounds just like we need a special recovery routine for this camera. I’ll have more info soon.

1 Like

Did some debugging. I think my unit stopped working. I’m no longer able to get it to do anything other than be discovered on startup. It never passes reset with any firmware I try. I’ve asked Ibrahim for help on this.

I’m not sure if this is a firmware issue, though. The particular Portenta board I have is an early unit that had issues with its USB logic. I might need to buy the latest stuff.

1 Like

Okay, followed Ibrahim’s PR here and increased the timeouts to 100ms and its alive again. misc: Increase delay after reset/power-down. by iabdalkader · Pull Request #2207 · openmv/openmv ( (1.1 MB)

Please try this firmware out and let me know your results. If this is stable we can modify the PR to just increase the Portena delays to 100ms (not other cameras).


This new firmware works well in this few days. No error. I’m going to see how it goes. Thank you.

Okay, please let us know if it’s stable after testing for a while and we will merge an update just for the Portenta.