Power button - board stuck in a boot loop


My board has developed a fault and I’m wondering if there is any known issues or fixes before I go probing around.

  1. When I press and hold the power button, the board boots and the RGB LED above the SDRAM blinks green, turns white, goes out. At the same time the windows computer detects USB normally.

  2. The board then disconnects USB and the RGB LED flashes again as previously.

  3. Repeat 1 & 2 ad infinitum.

I am powering the board by a 2A powered USB hub.

I have tried piggybacking a new momentary switch over the toggle switch contacts, with the same result.

Edit: forgot to mention the LED3 pulses green then goes solid green.

Thanks for any help.

You’re stuck in a boot loop, but you show us a schematic of your power controller. Do you feel there is an issue with that? Have you watched the activity on the latch Q-out to see if it is stable (not drooping) during your boot time. I use this circuit to control power on my portable devices with good results. “Push Button ON-OFF Soft Latch Circuits, Battery Powered Touch Toggle ON OFF Switch, Momentary Button MOSFET Power Switch for Microcontrollers” (latching press-on, hold - off) What are you using as a power switch? Relay, MOSFET, . . . Have you tried connecting the latch pin 1 via a resistor to Vcc? Is this intended to be a portable device? I use the Adafruit Power boost 1000C to boost the voltage from LiPo batteries.

The schematic section shown is from the Pure thermal board, not custom but it shows the switch I am toggling.
There is an issue at switch on as the board boot cycles.
I am asking if this is a known issue, with the board, before I break out the diagnostic tools, to save time.
Have a dig and you may find the whole Pure Thermal schematic.
I guess my question is for Pure Thermal hardware gurus.