OpenMV IDE 4.0.1 Fold Capability

I just downloaded OpenMV IDE 4.0.1, and I am having trouble using the ‘Toggle Fold All’ feature like I used in previous versions. It only seems to fold one small section of the code at the end of the 1500+ lines of code. I am also not seeing the ability to individually fold any blocks except for the last block in the code. I apologize if I’m just using the IDE incorrectly. Please advise. Thanks.

I removed the code folding completely since it was broken after the update it and I could not figure out why. It may start working again when I introduce full Python parsing via the Python plugin in Qt creator. Right now it’s all disabled and not visible.

How did it fold anything right now? It should be completely disabled.

If I either ‘Toggle Fold All’ or click inside of this block and select ‘Fold’, this one block folds. The code above this is either variable/constant declarations or functions. This is the main code that calls those functions. I can’t explain it!

I just tried to go back to v3.0.3 and now I’m getting the following error when I try to connect the camera. Do you know what file it is looking for or how I can fix this?

4.0.1 removes old resources from v3 and before to cleanup things.

Launch v3 with -upgrade_resources and it will install the the files it needs again. If the command line arg is wrong the IDE will show a dialog on how to pass it (writing this on my phone in the gym).

I see, so, the folding dialog pop up appeared. This managed to escape my testing.

Well… luckily now thanks to the new CI/CD system I can remote it folding there very quickly and do a release. Can you email me the file that causes the error?

I think I know why you have the issue. It’s because you probably enabled folding in the IDE under settings in v3.0.3. I hide the settings option in the new IDE, but, I probably didn’t disable the IDE from reading the old setting if set and applying it.

So, to fix this just install the latest IDE and then completely delete the <user_name>/AppData/Romaing/OpenMV IDE folder. This will remove all old setting and the IDE will apply the new settings without anything from the old IDE sneaking in.

I will re-enable this feature once I have the full python parsing working and the feature actually functions. When I did the update to Qt Creator 10.0.1 the feature was completely broken even though it worked before.