Openmv H7, Lepton 3.5 half of image dead

I had my lepton working for about 30 minutes, then i swapped to the lens provided with H7, the normal lens worked too. After i swapped back to lepton i have not been able to get it working again. Picture explains the situation better:

IDE also gives “sensor control failed”. Barely any fps, maybe couple images before it crashes.

I have tried to upload firmware and bootloader again, tried older versions too. No difference. Also made sure the connectors are good in both H7 and lepton adapter. Same things done in both windows and linux environment.

Lepton shouldnt be broken but starts feeling like it.

unforunatelly they are very sensitive.
are you sure you plugged it all the way in?

Yes, so it clicks. I also know how to deal with esd so that shouldnt be the case.

Well, our drivers are quite robust for that sensor.

I also personally unplug and replug the modules pretty regularly when testing… and they continue to work. I don’t really have any other answer for you other than it might have been damaged. I have a bunch of 2.5 modules with broken shutters and they still work… although the FFC algorithm nor longer works right because there’s no shutter.

Typically, when they break there’s just no video at all. It’s not usually partial video. For the ones that I have that don’t work they just don’t work at all.

so maybe there is a fault with the firmware.
today i have the same problem with h7 camera.
everything was working perfect.
i didnt touch the sensor at all.
WHen i decided to download the new ide and after the firmware update the same excact problem apeared. half of the image is ok and the rest excactly the same…
Please confirm that…

forgot to say that i have tested the sensor on an outdated camera h7 and works fine…
so i hope that you didnt throw away or disassembly your flir sensor my friend…

1 Like

Ok, this gives me some hope with the situation. Thankfully i still have the sensor. Now that you mentioned that you updated the IDE, i think the problem appeared to me too after updating the IDE.

Hi, there was an issue with the firmware. Here’s a fixed firmware for the H7 (non-plus). (1.1 MB)

1 Like