Need help with latest OpenMV IDE installation


I am unable to install latest OpenMV IDE (v 4.0.x) on Ubuntu 20.04.6 LTS machine. The error is attached below. It popped up during license-agreement setup, and clearing cache as suggested did not address the issue. Any idea how to solve it?

[9167] Critical: TypeError: Value is undefined and could not be converted to an object 
This may be solved by restarting the application after clearing the cache from: "... cache/qt-installer-framework/ ..."

Thank you!

No clue what’s causing that. I could make the installer build system output a tar.gz of the IDE if you’d like.

The installer should work fine with 20.04 as it’s built in GitHub runners for that. I guess you have something installed which is causing issues. The best thing I can do is post a archive of the files.

Thank you for your prompt reply. I have tried installing v 4.0.1 (on OpenMV download webpage) and v. 4.0.4 (in GitHub release), but they both failed. Currently, I could successfully install v 3.3. I am wondering if I can have the tar.gz of IDE for trying it out. Thank you!

Hi, generating this build output the right way will take a little bit of time. Should have the IDE updated with this fix in 2 days.


Actually, can you post the complete error log from the installer? It should have created a bunch of files when it ran. The installer log file should have the actual error with the installer. This is easier to fix than generating a tar.gz file.

Hi, here’s the latest IDE with a linux tar.gz now: Release v4.0.5 · openmv/openmv-ide · GitHub

Hello! Thank you very much for your kind support. I have successfully installed the version 4.0.5 now.

Hello again. I was trying to upload the firmware to Arduino Portenta after installing the IDE v4.0.5. However, the “DFU firmware update failed!” and “Timeout Error” kept popping up at the very beginning of uploading. Not sure what causes this issue. Thank you!

P.S. I tested uploading via Arduino IDE, and it was fine.

Ah, yeah, it’s the version of the DFU-Util we are probably using in the IDE. The issue happens related to USB packet errors and having an old version of the Arduino Portenta with bad hardware design.

You can fix this by copying and pasting the dfu-util from your Arduino installation over ontop of our DFU-Util under /share/dfu-util.

Other fixes are using a newer version of the Portenta where they fixed some hardware design issues and a potentially shorter USB cable.

Thank you for your advice. I will try it out.